[RTL][Lock Screen]The formatting of date in Arabic on lock screen is day of week, month, day from right to left.

VERIFIED WORKSFORME

Status

defect
P1
normal
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted image date.png
[1.Description]:
[RTL][Lock Screen]The format of Arabic date in lock screen is not shown as day of week, month, date.
See attachment:date.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic and enable Lock Screen.
1. Press power key to go to sleep mode.
2. Press power key again to lock screen.
3. Observe the date in lock screen. 

[3.Expected Result]: 
3. The formatting for Arabic is day of week, month, date.

[4.Actual Result]: 
3. The format of date is date, month, day of week.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
(Reporter)

Comment 1

4 years ago
Per P6 in 2014 Nov. spec, the formatting of date in lock screen for Arabic is day of week, month, date.
Duplicate of this bug: 1129601
 Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15378/
Flags: in-moztrap+
Priority: -- → P1
Assignee: nobody → augustin.trancart
If I'm not mistaken, the date format is defined in localization files.
Flags: needinfo?(francesco.lodolo)
Assignee: augustin.trancart → nobody
(In reply to Sue from comment #1)
> Per P6 in 2014 Nov. spec, the formatting of date in lock screen for Arabic
> is day of week, month, date.

Do we have specs for l10n and localization tests in moztrap? That would be entirely new to me.

Yes, locales are able to determine their date formats.
https://hg.mozilla.org/gaia-l10n/ar/file/7a4b4af9f24d/shared/date/date.properties#l197

I think lockscreen is using longDateFormat from system
https://hg.mozilla.org/gaia-l10n/ar/file/7a4b4af9f24d/apps/system/system.properties#l258

longDateFormat=%A, %B %e
(Full weekday name), (full month name) (day of the month as a decimal number)

If you think that's wrong for Arabic, you should move this to Mozilla Localizations::ar and discuss it with localizers.
Flags: needinfo?(francesco.lodolo)
Component: Gaia::System::Lockscreen → ar / Arabic
Product: Firefox OS → Mozilla Localizations
Flags: needinfo?(nefzaoui)
(In reply to Francesco Lodolo [:flod] from comment #5)
> (In reply to Sue from comment #1)
> > Per P6 in 2014 Nov. spec, the formatting of date in lock screen for Arabic
> > is day of week, month, date.
> 
> Do we have specs for l10n and localization tests in moztrap? That would be
> entirely new to me.
>

Just to answer to comment 5: I confirm UX did cover specs for Arabic when the created the RTL UX specs for 2.2.
(Reporter)

Comment 7

4 years ago
************Update the Expected Result************
The date format in Arabic language should be week, day, month from right to left.
(Reporter)

Updated

4 years ago
Summary: [RTL][Lock Screen]The formatting of date in lock screen is date, month, day of week. → [RTL][Lock Screen]The formatting of date in Arabic on lock screen is week, month, day from right to left.
(Reporter)

Updated

4 years ago
Summary: [RTL][Lock Screen]The formatting of date in Arabic on lock screen is week, month, day from right to left. → [RTL][Lock Screen]The formatting of date in Arabic on lock screen is day of week, month, day from right to left.
Hi Rami, I was just wondering if this had been fixed in the meantime? Please let us know here when you get to it :D
many thanks!
Flags: needinfo?(nefzaoui) → needinfo?(rami223)
Nominating this as getting a fix is important for 2.2
blocking-b2g: --- → 2.2?

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+

Comment 10

4 years ago
Issue is fixed, please verify
Flags: needinfo?(rami223)
Hi Lancy,
verifyme at Flame 2.2. Thanks!
Flags: needinfo?(yulan.zhu)
Keywords: verifyme
Hi Josh,
This problem is verified pass on latest build of Flame 2.2, per P6 in latest Arabic spec, the formatting of date in Arabic on lock screen should be shown as day of week, day, month from right to left.
See attachment:Verify1_Flame2.2_Pass.png
Reproducing rate:0/10

Flame 2.2 build (Unaffected):
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yulan.zhu)
Keywords: verifyme
Rami: please remember to close the bug as resolved-fixed when you make a change in Pootle, so we can then verify the fix. This helps us in our triage. thanks!
Lancy: in cases like these, please therefore close the bug since you've verified the fix (since localizer says in comment 10 he fixed it).
Closing the bug as resolved fixed as per comment 10
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
And now closing as verified fixed as per comment 12
Status: RESOLVED → VERIFIED
Typically we use the WORKSFORME resolution when a bug goes away without a clear patch landing to fix it.
Resolution: FIXED → WORKSFORME
(Reporter)

Updated

4 years ago
See Also: → 1159643
You need to log in before you can comment on or make changes to this bug.