[FFOS2.0][Woodduck][STK][Refresh]MS can't refresh MSISDN successful

RESOLVED FIXED in Firefox OS v2.0M

Status

Firefox OS
Gaia
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sync-1, Assigned: seanlee)

Tracking

unspecified
2.2 S6 (20feb)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.2 ?, b2g-master ?)

Details

Attachments

(8 attachments)

(Reporter)

Description

3 years ago
DEFECT DESCRIPTION:
 ->MS can't refresh MSISDN successful after perform refresh MSISDN
 
  REPRODUCING PROCEDURES:
 ->MS load simulated SIM card and SATK application which can send "Refresh" procative SIM command.
 ->Enter into "Settings->Commandes Proactives->Refresh->STN07002->MSISDN"
 ->Observe My Number in settings after refresh MSISDN
 
  EXPECTED BEHAVIOUR:
 ->MS should refresh MSISDN successful after perform refresh MSISDN
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 +86 151 1324 9081
(Reporter)

Comment 1

3 years ago
Created attachment 8562050 [details]
mtklog 907795
(Reporter)

Comment 2

3 years ago
Created attachment 8562051 [details]
sdn

Comment 3

3 years ago
Hi Sean,
Could you please help to check the problem? Thanks!
Blocks: 1054172, 1107999
Flags: needinfo?(selee)

Comment 4

3 years ago
Hi Mozilla,
  please ignore the first log. In the second log, we find msisdn has updated. But at settings->Device Information->Phone number, not update the number when execute refresh command to refresh MSISDN. Could you please help to update the number? Thank you.

old value:
"msisdn":"11001894790"
new value:
"msisdn":"0155663140"

--------------------log start--------------------
        Line 7868: 02-09 03:54:44.023   162   162 I Gecko   : -*-
RadioInterface[0]: Received message from worker:
{"iccType":"sim","iccid":"89441000000400617452","rilMessageType":"iccinfochange","rilMessageClientId":0,"mcc":"001","mnc":"01","ons":"Operateur
Name
String","ons_short_form":"FNAC","isDisplayNetworkNameRequired":true,"isDisplaySpnRequired":true,"msisdn":"11001894790","spn":"Vodafone"}
        Line 7877: 02-09 03:54:44.190   162   630 I Gecko   : RIL Worker: [0]
readingSST:MSISDN:
        Line 7878: 02-09 03:54:44.191   162   630 I Gecko   : RIL Worker: [0]
MSISDN: MSISDN is available
        Line 7878: 02-09 03:54:44.191   162   630 I Gecko   : RIL Worker: [0]
MSISDN: MSISDN is available
        Line 8105: 02-09 03:54:46.044   162   630 I Gecko   : RIL Worker: [0]
MSISDN: 0155663140
        Line 8107: 02-09 03:54:46.048   162   162 I Gecko   : -*-
RadioInterface[0]: Received message from worker:
{"iccType":"sim","iccid":"89441000000400617452","rilMessageType":"iccinfochange","rilMessageClientId":0,"mcc":"001","mnc":"01","ons":"Operateur
Name
String","ons_short_form":"FNAC","isDisplayNetworkNameRequired":true,"isDisplaySpnRequired":true,"msisdn":"0155663140","spn":"Vodafone"}
--------------------log end--------------------------
(Assignee)

Comment 5

3 years ago
Hi Pengfei,

Will Phone number in Settings app be shown correctly after rebooting the phone?
Flags: needinfo?(selee)

Comment 6

3 years ago
(In reply to Sean Lee [:seanlee] from comment #5)
> Hi Pengfei,
> 
> Will Phone number in Settings app be shown correctly after rebooting the
> phone?
  Yes, it's correct after rebooting.
Sean, per comment 6 the phone number in Settings app is correct after reboot.
Flags: needinfo?(selee)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(selee)
Resolution: --- → DUPLICATE
Duplicate of bug: 1132363
(Assignee)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 9

3 years ago
Created attachment 8563280 [details] [diff] [review]
Trail Patch for v2.0m

Hi Pengfei,

Could you help to test the trail patch? Thank you.
Flags: needinfo?(pengfei.huang.hz)

Comment 10

3 years ago
Created attachment 8563292 [details]
mtklog_SDN_PASS.zip

Hi Sean,
  we see the Phone number changed. Test pass.
  Nice patch. Thank you very much.
Flags: needinfo?(pengfei.huang.hz)
(Assignee)

Comment 11

3 years ago
Created attachment 8563295 [details] [diff] [review]
Trail Patch for v2.0m

Hi Pengfei,

Could you help to try this patch again?
This one is simpler and removed debug messages.
Thank you.
Flags: needinfo?(pengfei.huang.hz)
(Assignee)

Updated

3 years ago
Assignee: nobody → selee
Status: REOPENED → ASSIGNED

Comment 12

3 years ago
Hi Sean,
  Yeah, patch works well. Pass the test.
Flags: needinfo?(pengfei.huang.hz)
(Assignee)

Updated

3 years ago
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
Created attachment 8563930 [details] [review]
[gaia] weilonge:seanlee/Settings/v2.1/Bug1131552 > mozilla-b2g:v2.1
Created attachment 8563931 [details] [review]
[gaia] weilonge:seanlee/Settings/v2.0m/Bug1131552 > mozilla-b2g:v2.0m
(Assignee)

Comment 15

3 years ago
Created attachment 8563932 [details] [review]
PR for v2.0m

Hi Arthur,

Could you help to review this patch for v2.0m?
Thank you.
Attachment #8563932 - Flags: review?(arthur.chen)
Comment on attachment 8563932 [details] [review]
PR for v2.0m

Good job! r=me.
Attachment #8563932 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 17

3 years ago
Arthur, Thank you!

landed on v2.0m : https://github.com/mozilla-b2g/gaia/commit/a1b5959728c8bc2a82354e197bb161922d419866
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

3 years ago
Comment on attachment 8563932 [details] [review]
PR for v2.0m

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):

[User impact] if declined:
Phone Number in Settings/About will not be updated when msisdn or mdn is changed.

[Testing completed]:
1. Partner tested PASS in their LAB.
2. Unit test tested PASS.

[Risk to taking this patch] (and alternatives if risky):
Only changed at Settings app. Very minor risk.

[String changes made]:
None
Attachment #8563932 - Flags: approval-gaia-v2.1?

Updated

3 years ago
Attachment #8563932 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/5d3479fdd438412adee4452720856b6b771fe5cd

Are v2.2/v3.0 unaffected?
status-b2g-v2.0M: affected → fixed
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: --- → ?
status-b2g-master: --- → ?
Flags: needinfo?(selee)
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Comment 20

3 years ago
Hi Ryan,

Thanks for your concern.

This patch is tested by TCL on v2.0m, and v2.1 has the same architecture. I think there is no much risk to cherry-pick to v2.1.

Settings app has a lot of architecture changes on v2.2/v3.0, so we need to discuss if it's really affected to v2.2/v3.0.

Hi Arthur,

Do you think this issue is affected to v2.2/v3.0?
IMHO, we need to listen event 'iccinfochange' and invoke '_loadHardwareInfo' to update the information.
I think the modification would be in HardwareInfo.prototype.init .
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/panels/about/hardware_info.js#L29

Do you have any suggestions?

Thank you!
Flags: needinfo?(selee)
(Assignee)

Updated

3 years ago
Flags: needinfo?(arthur.chen)
Yes, the change should be made to the code you mentioned. The only difference would be in v2.2 and 3.0 it is discouraged to use IccHelper as it is planned to be deprecated. Please use SimSlotManager in the shared folder instead.
Flags: needinfo?(arthur.chen)

Updated

3 years ago
blocking-b2g: --- → 2.0M+
(Reporter)

Comment 22

3 years ago
Dear Wayne Teng,
   we can close this bug, please see TCL bug907795.
   Thanks.
You need to log in before you can comment on or make changes to this bug.