Closed Bug 1131631 Opened 5 years ago Closed 5 years ago

[Dialer] bdi tag remains in conference call participants screen

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

x86
macOS
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: thills, Assigned: thills)

References

Details

Attachments

(2 files)

STR:

1. Create a conference call
2.  Go to the conference participants list
Expected:  Should see the string "conference (2)" 
Actual:  See the string "<bdi> conference (2) </bdi"

I believe this was introduced by bug 1126850.
Blocks: dialer-rtl
Assignee: nobody → fabien
Priority: -- → P1
feature-b2g: --- → 2.2+
Assignee: fabien → thills
Status: NEW → ASSIGNED
Attached file PR for a fix
Attachment #8566715 - Flags: review?(gsvelto)
Comment on attachment 8566715 [details] [review]
PR for a fix

Redirecting to drs.
Attachment #8566715 - Flags: review?(gsvelto) → review?(drs.bugzilla)
Comment on attachment 8566715 [details] [review]
PR for a fix

Looks good, but I left one nit on the PR. Please fix that before landing. This will also retrigger the tests, which don't seem to have run.
Attachment #8566715 - Flags: review?(drs.bugzilla) → review+
https://github.com/mozilla-b2g/gaia/commit/a21a75c8b9666f6f71b4f247d8a9258e725e65e0
https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=412b044c039c

NI to myself to ask for uplift.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(thills)
Resolution: --- → FIXED
Comment on attachment 8566715 [details] [review]
PR for a fix

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Regression caused by 1126850
[User impact] if declined: User would see <bdi>Conference(2)</bdi> on the conf call participants page.  BDI tags should not be visible.  It will be a bad ux.
[Testing completed]:yes
[Risk to taking this patch] (and alternatives if risky):low
[String changes made]:no
Flags: needinfo?(thills)
Attachment #8566715 - Flags: approval-gaia-v2.2?(release-mgmt)
Reassigning to Bhavana (release-mgmt@mozilla.com is now about Firefox Desktop)
Flags: needinfo?(bbajaj)
Flags: needinfo?(bbajaj)
Attachment #8566715 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2?(bbajaj)
Attachment #8566715 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual results:  The bdi tag is not shown on the cal participant screen.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150227010229
Gaia: 7512026a377271a0cade12d70846557f0bc7781c
Gecko: c7968255c1ea
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150227002521
Gaia: eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gecko: c8a38dcfbebc
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.