Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Cannot use shortcut of single key(e.g., space key, "/", "'", "F", "N", "B", "P" and "T") if IME is active

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
Internationalization
P1
major
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: Koike Kazuhiko, Assigned: masayuki)

Tracking

({inputmethod, intl})

Trunk
mozilla1.9alpha1
inputmethod, intl
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Can't scroll by space bar if IME is active.

IME should be off if caret isn't in input or textarea.

Original report in Bugzilla-jp:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=1363

Comment 1

16 years ago
Changed QA contact to ylong@netscape.com.
Keywords: intl
QA Contact: teruko → ylong

Updated

16 years ago
Status: NEW → ASSIGNED

Updated

16 years ago
Target Milestone: --- → mozilla0.9.8

Comment 2

16 years ago
I spent few hours on this; but failed to identify where 'x20' WM_CHAR msg
gets translated to a PageDwn command.  I was hoping to add the IME
state code there so that it also send PageDwn command.

cc'ing bunch of people for more exposure.
Whiteboard: need help

Comment 3

16 years ago
push off to 1.0.1
Target Milestone: mozilla0.9.8 → mozilla1.0.1

Updated

16 years ago
Keywords: nsbeta1

Comment 4

16 years ago
japanese and korean IME have this problem. not reproduceable with simp chinese
and trad chiense IME. 
nsbeta1- because there are other keystrock to do that- such as pagedown , etc.
Keywords: nsbeta1 → nsbeta1-

Comment 5

16 years ago
Maybe, IME must be deactivated when no text input area has focus.
IME eats not only 'space' but also other shortcut key strokes too.

Comment 6

14 years ago
*** Bug 194778 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 239837 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Depends on: 55751
(Assignee)

Updated

13 years ago
Assignee: yokoyama → masayuki
Severity: normal → major
Status: ASSIGNED → NEW
OS: Windows 2000 → All
Hardware: PC → All
Summary: Can't scroll by space bar if IME is active → Cannot use shortcut of single key(e.g., space key, "/", "'", "F", "N", "B", "P" and "T") if IME is active
Target Milestone: mozilla1.0.1 → Future
(Assignee)

Updated

13 years ago
Depends on: 276727
(Assignee)

Updated

12 years ago
Blocks: 279246
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: Future → mozilla1.9alpha
(Assignee)

Updated

12 years ago
Whiteboard: need help
If you want to track this bug, see bug 55751. This is fixed by bug 55751.
Priority: P2 → P1
(Assignee)

Updated

12 years ago
Depends on: 309578
fixed by bug 55751.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
-> REOPEN

backed-out the patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Depends on: 321468
(Assignee)

Updated

11 years ago
Depends on: 358899
Duplicate of this bug: 429810
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.