[RTL][Contacts] - The icons overlap the text for the import / export contacts buttons on the contacts settings page

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: jfkthame)

Tracking

({regression})

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(3 attachments)

Reporter

Description

4 years ago
Description:
On the contacts settings page there are two 'transfer contacts' buttons; one for import and one for export. Each button has an icon on it of a torso and direction arrow. In RTL, these icons overlap the button text

Repro Steps:
1) Update a Flame to 20150211010216 and set language to an RTL language (Arabic)
2) Open contacts
3) Select Settings

Actual:
icons overlap the import / export button text

Expected:
icons will be most right aligned and the text will be spaced next to it

Environmental Variables:
Device: Flame 3.0
Build ID: 20150211010216
Gaia: 8c7865486a1b11076b849bbf8f7fccbaffbfafe7
Gecko: ee093ca70666
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 4/4
See attached: screenshot

---------------------------------------------------------------------------------

Issue does NOT reproduce in 2.1

Actual results - icons do not overlap 

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150211002505
Gaia: 943be6fd146017dcd9d4c9d1027be1e43bad13eb
Gecko: e614443583e7
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:

Identifiable regression of a supported feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
Bug 1130231 seems to have caused this issue.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150209063429
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: c13e7799a147
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150209064732
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 70a1847bdc20
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 70a1847bdc20

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: c13e7799a147

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c13e7799a147&tochange=70a1847bdc20
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Jonathan, can you take a look at this please? Looks like bug 1130231 might have caused this to occur. Can we get this backed out on Master?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker) → needinfo?(jfkthame)
Assignee

Comment 4

4 years ago
I suspect this is a Gaia CSS issue, similar to bug 1132194 and bug 1131827; the fix in bug 1130231 is exposing cases where Gaia's CSS is not correct for RTL, but happened to work with the previous (buggy) behavior of button padding.
Assignee

Updated

4 years ago
Flags: needinfo?(jfkthame)
Assignee

Comment 6

4 years ago
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

Here's another example of direction-specific padding within a button, exposed by fixing bug 1130231.
Attachment #8563575 - Flags: review?(mhenretty)
triage: not marking for feature-b2g:2.2 at this time because it's marked as unaffected, but if this does show up on 2.2, please request approval for uplift.
Priority: -- → P2
Dylan, we need to add feature-b2g:2.2, since 2.2 will be affected once bug 1130231 lands.
Assignee: nobody → jfkthame
Flags: needinfo?(doliver)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

Thanks!
Attachment #8563575 - Flags: review?(mhenretty) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

Ah duh, I'm not a system peer. Kevin, could you stamp this?
Attachment #8563575 - Flags: review?(kgrandon)
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

This seems to be a contacts patch, which I'm not a peer of. Forwarding the request to Francisco.
Attachment #8563575 - Flags: review?(kgrandon) → review?(francisco)
feature-b2g: --- → 2.2+
Flags: needinfo?(doliver)
Clearing the blocking 3.0 nom as already tracked under the feature flag.
blocking-b2g: 3.0? → ---
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

Francisco is a bit swamped this week. Jose, can you take a look?
Attachment #8563575 - Flags: review?(francisco) → review?(jmcf)
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

LGTM

thanks
Attachment #8563575 - Flags: review?(jmcf) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8563575 [details] [review]
[gaia] jfkthame:jfkthame-patch-1 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 1130231 

[User impact] if declined:
Broken UI for RTL on contacts import/export form.

[Testing completed]:
Manually tested.

[Risk to taking this patch] (and alternatives if risky):
Low risk as it's a css only change. No alternative if we want this fixed for RTL.

[String changes made]: none.
Attachment #8563575 - Flags: approval-gaia-v2.2?
Attachment #8563575 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is veried fixed on the latest Nightly Flame 3.0 build.  Adding verifyme tag so this can get checked once the 2.2 uplift occurs.
	
Actual Results: The icons and text do not overlap.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)

Comment 20

4 years ago
This issue has been verified successfully on latest Flame2.2
Verify picture:"2015-02-27-11-29-03.png"
Occur Rate: 0/10

Flame 2.2 build:
Build ID               20150226162510
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1be266320634
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.195624
Firmware Date          Thu Feb 26 19:56:35 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [Qanalyst-triage+][rtl-impact][MGSEI-triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.