Closed Bug 1132377 Opened 5 years ago Closed 5 years ago

Privacy Contribution Configuration

Categories

(Firefox OS Graveyard :: General, defect, P1)

Other
Other
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: wmathanaraj, Assigned: etienne)

References

Details

Attachments

(1 file, 1 obsolete file)

As discussed with Lou Schreier there are far too many bugs that remain open with the privacy work for us to be confident to leave the feature on by default.

We need to fix most of the open bugs to be able to leave the features visible by default.

As such we will configure the privacy contribution by default not visible  - but if OEM and operator would like to have the feature they can switch it on for their specific build. 

When all open bugs are fixed then we can revisit integration of these features into the core functionality and removing these configuration flags.
blocking-b2g: 2.2? → 2.2+
would like a list of those bugs which are described in 
"We need to fix most of the open bugs to be able to leave the features visible by default." to see what the scope of the issues are.
Flags: needinfo?(wmathanaraj)
(In reply to Louis from comment #1)
> would like a list of those bugs which are described in 
> "We need to fix most of the open bugs to be able to leave the features
> visible by default." to see what the scope of the issues are.

Hi Louis, 
You can check bug 1057675 as PP meta and also https://wiki.mozilla.org/PrivacyPanel for PP current status on 2.2.
Flags: needinfo?(wmathanaraj)
Etienne, will you help us out with this bug?
Flags: needinfo?(etienne)
Flags: needinfo?(etienne)
Attachment #8566991 - Flags: review?(timdream)
Assignee: nobody → etienne
Status: NEW → ASSIGNED
Attachment #8566991 - Flags: review?(timdream) → review+
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
https://github.com/mozilla-b2g/gaia/commit/c046b1ca9a95ca132e558ac1b24fdc170907c5f4
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Etienne,
Could you provide a fix on 2.2 as we need this patch in 2.2 as well?
Thanks!
Flags: needinfo?(etienne)
Comment on attachment 8572579 [details] [review]
[gaia] etiennesegonzac:bug-1132377 > mozilla-b2g:master

The commit that landed was empty :) (merge issue).
Opened a new PR with a rebased patch, will land once I get a green try and ask for 2.2 approval.
Flags: needinfo?(etienne)
Attachment #8572579 - Flags: review+
Attachment #8566991 - Attachment is obsolete: true
Comment on attachment 8572579 [details] [review]
[gaia] etiennesegonzac:bug-1132377 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): not really a bug
[User impact] if declined: partner request
[Testing completed]: the privacy panel does not appear in homescreen or settings app
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: none
Attachment #8572579 - Flags: approval-gaia-v2.2?
Attachment #8572579 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Hi Etienn,

This is Josh, EPM of Privacy Panel. 
I had a discussion with Bhavana and we would like to know is it possible to back this fix out for 2.2 and land again on FC 2015/4/6?

The reason is because there are still many Privacy Panel bugs and also l10n works are still on going. QA then need to build driver by their own with "Privacy Panel" enabled.

It would be easier for them if we can back this out for now which they can still have PVT build for testing.

Can you help with this? Thank you very much!
Flags: needinfo?(etienne)
Hi Etienn & Josh,
I found that only user build removes privacy controls panel. Engineering build doesn't remove the privacy controls panel. I can still use engineering build to test. 
So, I don't think we need to back out the codes right now.

Build information:
Gaia-Rev        2058b7a556ab1259952ac46b9b6118fdd6464eaf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/bf2032b69113
Build-ID        20150311162504
Version         37.0
Device-Name     flame
FW-Release      4.4.2
Flags: needinfo?(etienne)
Hi Gerry,
Thanks for the info. However Delphine bring concern from l10n testers not able to use ENg build:

"I'm afraid localizers won't benefit from the Engineering buids since the public ones only have pseudo-locales enabled - so this wouldn't help them to test their work (unless I'm missing something, https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame states only User Build have all locales)"

Hi Etienn, do you have other concern? Thanks.
Flags: needinfo?(etienne)
(In reply to Josh Cheng [:josh] from comment #15)
> Hi Gerry,
> Thanks for the info. However Delphine bring concern from l10n testers not
> able to use ENg build:
> 
> "I'm afraid localizers won't benefit from the Engineering buids since the
> public ones only have pseudo-locales enabled - so this wouldn't help them to
> test their work (unless I'm missing something,
> https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/
> Updating_your_Flame states only User Build have all locales)"
> 
> Hi Etienn, do you have other concern? Thanks.

It's more of a sheriffing/release management issue. I don't have any concern about this patch getting backed out and re-landed.
Flags: needinfo?(etienne)
I believe Bhavana mentioned this should be OK from her perspective during our roundtable yesterday.
ni on her as per comment 16. thanks!
Flags: needinfo?(bbajaj)
Hi Kai-Zhen,
Can you help to back this patch out for now and we can assess again to land this back right before FC.
Thanks!
Flags: needinfo?(kli)
(In reply to Delphine Lebédel [:delphine - use need info] from comment #17)
> I believe Bhavana mentioned this should be OK from her perspective during
> our roundtable yesterday.
> ni on her as per comment 16. thanks!

yes, josh lets make sure to tack this so we don't drop the ball on re-landing before ship. Thanks!
Flags: needinfo?(bbajaj)
Whiteboard: [NO_UPLIFT}
QA Whiteboard: [COM=Privacy Panel]
(In reply to Kai-Zhen Li [:kli][:seinlin] from comment #20)
> Patch is reverted in v2.2.
> https://github.com/mozilla-b2g/gaia/commit/
> a6b2d3f8478ec250beb49950fecbb8a16465ff6f

Hi Kai-Zhen,
As communicated previously. Could you help to land this back today as we have passed FxOS 2.2? Thanks!
Flags: needinfo?(kli)
Hi Wilfred,
I think we should also land this on master right?
Flags: needinfo?(wmathanaraj)
This patch is already in master [1]. Now it is also landed in v2.2 [2].

[1] master: https://github.com/mozilla-b2g/gaia/commit/799736283f454bee0e67760a525bcb058ac80e2b
[2] v2.2: https://github.com/mozilla-b2g/gaia/commit/5e09637414269728f6f1bc0152d0160f3b6b380e
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(kli)
Whiteboard: [NO_UPLIFT}
You need to log in before you can comment on or make changes to this bug.