Selection of sevral <select> items may disappear, when trying to select one more

VERIFIED DUPLICATE of bug 109318

Status

()

VERIFIED DUPLICATE of bug 109318
17 years ago
17 years ago

People

(Reporter: avm, Assigned: rods)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011129

When already have several items selected and trying to select 
one more item, selection may disappear.

Reproducible: Always

Steps to Reproduce:
1.Load http://bugzilla.mozilla.org/query.cgi or testcase (attached)
2.Press Ctrl and select 3-4 items in Status column
3.Don't release Ctrl key, click on next item and drag mouse right(A bit, 3-4
dots will be enough)
4.Please note, that only last item selected and selection disappear
from previously selected items. 

Actual Results:  Selection disappear from selected items.

Expected Results:  When Ctrl key pressed anyone should be able to add some items
to already selected.

Can't found any similar bug. May be it is related to 27315 ?

Comment 1

17 years ago
I see this happening on 
window2000  -- build 2001-12-03-06trunk
RedHat Linux 7.1  -- build 2001-12-10-06trunk

The selections made in the select box, with attribute multiple, is deselected 
randomly. This happens whether the select box is whitin a table or not.

these are the 2 testcases u can refer to:-
http://bubblegum/browser/standards/form-controls/tcase/Transitional-doctype/sele
ct-multipleselection.html

http://bubblegum/browser/standards/form-controls/tcase/Transitional-doctype/sele
ct-multipleselection-TABLE.html

Remember  - the deselection of previously selected items happens randomly.
Severity: minor → normal
Keywords: testcase
OS: Linux → All

Comment 2

17 years ago
Created attachment 61128 [details]
testcase <select multiple> without table

Comment 3

17 years ago
Created attachment 61129 [details]
testcase <select multiple> within Table

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 109318 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
Verified DUP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.