[RTL][Contacts] Icons are Left Aligned in Import/Export Contacts menus.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: Nefzaoui)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8563519 [details]
RTL Contacts Left Align.png

Description:
If the user selects  Import or Export Contacts in the Contacts Settings menu, they will see that the icons for SIM, Memory Card, Gmail, Outlook, and Bluetooth are improperly left aligned

Repro Steps:
1) Update a Flame to 20150212010213
2) Open the Contacts app
3) Tap the 'Gear' icon to open the Settings menu.
4) Select 'Import Contacts'

Actual:
Icons are left aligned.

Expected:
Icons are Right Aligned.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150212010213
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 3094601af679
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: screenshot

------------------------------------------

This issue DOES occur on Flame 2.2.
Icons are left aligned.

Environmental Variables:
Device: Flame 2.2
Build ID: 20150212002504
Gaia: 791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gecko: 5dec207fcbeb
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][rtl-impact]
triage: P2. inconsistent with spec & Settings app but does not cause confusion or impede functionality.
Priority: -- → P2
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Created attachment 8565379 [details] [review]
[gaia] anefzaoui:bug-1132551 > mozilla-b2g:master
(Assignee)

Updated

4 years ago
Attachment #8565379 - Flags: review?(francisco)
(Assignee)

Updated

4 years ago
Assignee: nobody → nefzaoui
Comment on attachment 8565379 [details] [review]
[gaia] anefzaoui:bug-1132551 > mozilla-b2g:master

Looking great thanks!
Attachment #8565379 - Flags: review?(francisco) → review+
(Assignee)

Comment 4

4 years ago
Thanks!
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
Comment on attachment 8565379 [details] [review]
[gaia] anefzaoui:bug-1132551 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Lack of RTL implementation
[User impact] if declined: icons misplaced: attachment 8563519 [details]
[Testing completed]: yes, flame
[Risk to taking this patch] (and alternatives if risky): RTL-specific css addition, very low risk
[String changes made]: none
Attachment #8565379 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8565379 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/bee6813ec27d76ba4260ead1263597641b28bf39
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S6 (20feb)
This issue is fixed in the latest Nightly 3.0 Flame build.  

Results:  The icons are on the right.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


In the latest Nightly 2.2 Flame build the icons are on the right but overlap with the text, likely as a results of bug 1130231 being uplifted to 2.2.

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
There is a bug for the overlap already written as bug 1132672.
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.