Closed Bug 1132783 Opened 5 years ago Closed 5 years ago

Intermittent browser_animation_play_pause_button.js,browser_animation_playerWidgets_disables_on_finished.js,browser_animation_toggle_button_resets_on_navigate.js | Test timed out

Categories

(DevTools :: Inspector, defect)

x86
Linux
defect
Not set

Tracking

(firefox36 unaffected, firefox37 unaffected, firefox38 fixed, firefox-esr31 unaffected)

RESOLVED FIXED
Firefox 38
Tracking Status
firefox36 --- unaffected
firefox37 --- unaffected
firefox38 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: pbro)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Calling this a regression from bug 1129454 given the timing.

15:41:07 INFO - 20 INFO TEST-START | browser/devtools/animationinspector/test/browser_animation_play_pause_button.js
15:41:21 INFO - 1423784481117 Browser.Experiments.Experiments TRACE Experiments #0::enabled=true, true
15:41:21 INFO - 1423784481124 Browser.Experiments.Experiments TRACE Experiments #0::Registering instance with Addon Manager.
15:41:21 INFO - 1423784481125 Browser.Experiments.Experiments TRACE Experiments #0::Registering previous experiment add-on provider.
15:41:21 INFO - 1423784481127 Browser.Experiments.Experiments TRACE PreviousExperimentProvider #0::startup()
15:41:21 INFO - 1423784481129 Browser.Experiments.Experiments TRACE Experiments #0::_loadFromCache
15:41:21 INFO - 1423784481149 Browser.Experiments.Experiments TRACE Experiments #0::_loadTask finished ok
15:41:21 INFO - 1423784481150 Browser.Experiments.Experiments TRACE Experiments #0::_run
15:41:21 INFO - 1423784481154 Browser.Experiments.Experiments TRACE Experiments #0::_main iteration
15:41:21 INFO - 1423784481155 Browser.Experiments.Experiments TRACE Experiments #0::_evaluateExperiments
15:41:21 INFO - 1423784481160 Browser.Experiments.Experiments TRACE Experiments #0::_main finished, scheduling next run
15:42:37 INFO - Xlib: extension "RANDR" missing on display ":0".
15:42:39 INFO - TEST-INFO | screentopng: exit 0
15:42:39 INFO - 21 INFO checking window state
15:42:39 INFO - 22 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource://app/modules/sessionstore/TabState.jsm" line: 96}]
15:42:39 INFO - 23 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource://app/modules/sessionstore/TabState.jsm" line: 96}]
15:42:39 INFO - 24 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource://app/modules/sessionstore/TabState.jsm" line: 96}]
15:42:39 INFO - 25 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource://app/modules/sessionstore/TabState.jsm" line: 96}]
15:42:39 INFO - 26 INFO Entering test
15:42:39 INFO - 27 INFO Adding a new tab with URL: 'http://example.com/browser/browser/devtools/animationinspector/test/doc_simple_animation.html'
15:42:39 INFO - 28 INFO Loading the helper frame script chrome://mochitests/content/browser/browser/devtools/animationinspector/test/doc_frame_script.js
15:42:39 INFO - 29 INFO Loading the helper frame script chrome://browser/content/devtools/frame-script-utils.js
15:42:39 INFO - 30 INFO URL 'http://example.com/browser/browser/devtools/animationinspector/test/doc_simple_animation.html' loading complete
15:42:39 INFO - 31 INFO Opening the toolbox with the inspector selected
15:42:39 INFO - 32 INFO Making sure that the toolbox's frame is focused
15:42:39 INFO - 33 INFO Switching to the animationinspector
15:42:39 INFO - 34 INFO Waiting for the inspector and sidebar to be ready
15:42:39 INFO - 35 INFO Console message: 1423784481117 Browser.Experiments.Experiments TRACE Experiments #0::enabled=true, true
15:42:39 INFO - 36 INFO Console message: 1423784481124 Browser.Experiments.Experiments TRACE Experiments #0::Registering instance with Addon Manager.
15:42:39 INFO - 37 INFO Console message: 1423784481125 Browser.Experiments.Experiments TRACE Experiments #0::Registering previous experiment add-on provider.
15:42:39 INFO - 38 INFO Console message: 1423784481127 Browser.Experiments.Experiments TRACE PreviousExperimentProvider #0::startup()
15:42:39 INFO - 39 INFO Console message: 1423784481129 Browser.Experiments.Experiments TRACE Experiments #0::_loadFromCache
15:42:39 INFO - 40 INFO Console message: 1423784481149 Browser.Experiments.Experiments TRACE Experiments #0::_loadTask finished ok
15:42:39 INFO - 41 INFO Console message: 1423784481150 Browser.Experiments.Experiments TRACE Experiments #0::_run
15:42:39 INFO - 42 INFO Console message: 1423784481154 Browser.Experiments.Experiments TRACE Experiments #0::_main iteration
15:42:39 INFO - 43 INFO Console message: 1423784481155 Browser.Experiments.Experiments TRACE Experiments #0::_evaluateExperiments
15:42:39 INFO - 44 INFO Console message: 1423784481160 Browser.Experiments.Experiments TRACE Experiments #0::_main finished, scheduling next run
15:42:39 INFO - 45 INFO Console message: 1423784512514 Services.HealthReport.HealthReporter WARN Saved state file does not exist.
15:42:39 INFO - 46 INFO TEST-UNEXPECTED-FAIL | browser/devtools/animationinspector/test/browser_animation_play_pause_button.js | Test timed out - expected PASS
15:42:39 INFO - 47 INFO MEMORY STAT vsize after test: 599289856
15:42:39 INFO - 48 INFO MEMORY STAT residentFast after test: 149651456
15:42:39 INFO - 49 INFO MEMORY STAT heapAllocated after test: 52621532
15:42:39 INFO - 50 INFO TEST-OK | browser/devtools/animationinspector/test/browser_animation_play_pause_button.js | took 91038ms
Flags: needinfo?(pbrosset)
This is definitely a regression from bug 1129454 where I changed the way that tests wait for the animation panel to be initialized (function openAnimationInspector in browser/devtools/animationinspector/test/head.js).
I'll take a look at this now.
Assignee: nobody → pbrosset
Flags: needinfo?(pbrosset)
Duplicate of this bug: 1132838
Summary: Intermittent browser_animation_play_pause_button.js,browser_animation_playerWidgets_disables_on_finished.js | Test timed out → Intermittent browser_animation_play_pause_button.js,browser_animation_playerWidgets_disables_on_finished.js,browser_animation_toggle_button_resets_on_navigate.js | Test timed out
Since this is a bug with the init sequence of the animationinspector tests, any of the tests in the folder can basically intermittently fail now ...
Pushed a patch with a change to the test init sequence to try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6fe9d330bf32
Brian, this change to head.js was made to avoid animation tests from failing intermittently with e10s.
The animation tab init sequence goes like this:
- the sidebar panel is created (and the inner iframe is added and loaded)
- the sidebar widget calls the global 'setPanel' function on the window object in the iframe, without waiting for it to end (it doesn't care about the return value being a promise)
- that starts the AnimationsController init
- and once done, the AnimationsPanel init is done too.

The function in head.js used to just wait for an event that is emitted at the end of the AnimationsPanel init function execution. But it turns out that, with e10s, the event has already been emitted by the time we listen to it in the test.

So the simple fix was: either use the 'AnimationsPanel.initialized' promise when it exists (meaning that the init has already started or even maybe finished) or subscribe to the event.

This should be enough to cover all cases, and the try push I linked to above seems to confirm this.
Attachment #8564111 - Flags: review?(bgrinstead)
Comment on attachment 8564111 [details] [diff] [review]
bug1132783-intermittent-animation-tests.patch

Review of attachment 8564111 [details] [diff] [review]:
-----------------------------------------------------------------

Sounds good
Attachment #8564111 - Flags: review?(bgrinstead) → review+
Patrick, you're AFK on IRC, so I went ahead and landed this for you given the frequency and widespread nature of the failures. Hopefully you don't mind :)
https://hg.mozilla.org/integration/fx-team/rev/248aac04b9d8
Flags: in-testsuite+
Whiteboard: [fixed-in-fx-team]
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #11)
> Patrick, you're AFK on IRC, so I went ahead and landed this for you given
> the frequency and widespread nature of the failures. Hopefully you don't
> mind :)
> https://hg.mozilla.org/integration/fx-team/rev/248aac04b9d8
Thanks!
https://hg.mozilla.org/mozilla-central/rev/248aac04b9d8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.