Flash stutters with Shumway enabled

RESOLVED INVALID

Status

Firefox Graveyard
Shumway
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: Paul [pwd], Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150204150234

Steps to reproduce:

If a video doesn't play in Shumway and a user then reloads the video in Flash, the video stutters. However when disabling Shumway completely, the video plays fine.
Component: Untriaged → Shumway
Paul, thanks for the report. Can you please give us some more specific steps to reproduce? What URL do you see this on? What's your system configuration? Do you have any additional addons installed?
Flags: needinfo?(pwd.mozilla)
(Reporter)

Comment 2

2 years ago
http://bit.ly/1B79j5W

There's only one video working on that page (the bottom one), but it should demonstrate the issue adequately.
Flags: needinfo?(pwd.mozilla)
(In reply to Paul [pwd] from comment #2)
> http://bit.ly/1B79j5W
> 
> There's only one video working on that page (the bottom one), but it should
> demonstrate the issue adequately.

I really can't tell which SWF on that page you mean. Is only that SWF affected? If not, can you perhaps provide a link with just the one affected SWF?

Also, it'd be great to have the additional info I asked for in comment 1.
Flags: needinfo?(pwd.mozilla)
(Reporter)

Comment 4

2 years ago
Apologies, is this what you're looking for [1]? I'm seeing the problem with all flash dependent video. Shumway doesn't play it and so I'm using the flash fallback.

[1] Right click 'Show URL' provides this: http://embed.novamov.com/player/cloudplayer.swf

Also here's the rest of the info you asked for. Apologies for missing that request the first time around:

Application Basics
------------------

Name: Firefox
Version: 38.0a1
Build ID: 20150204150234
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0
Multiprocess Windows: 0/1 (default: false)

Extensions
----------

Name: Adblock Plus
Version: 2.6.7.3896
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Brief
Version: 2.0b3
Enabled: true
ID: brief@mozdev.org

Name: British English Dictionary
Version: 1.19.1
Enabled: true
ID: en-GB@dictionaries.addons.mozilla.org

Name: Bugzilla Tweaks
Version: 1.12.1.1
Enabled: true
ID: jid0-qBnIpLfDFa4LpdrjhAC6vBqN20Q@jetpack

Name: Customize about:newtab
Version: 1.1.4
Enabled: true
ID: customizenewtab@alejandrobrizuela.com.ar

Name: DictionarySearch
Version: 28.0.0
Enabled: true
ID: {a0faa0a4-f1a7-4098-9a74-21efc3a92372}

Name: Firefox Interest Dashboard
Version: 0.9.1
Enabled: true
ID: firefox.interest.dashboard@up.mozilla

Name: FlashGot
Version: 1.5.6.10rc6
Enabled: true
ID: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Name: ImageSearch
Version: 0.3.1
Enabled: true
ID: jid1-NOlwYOe3E3vApg@jetpack

Name: NoScript
Version: 2.6.9.14rc1
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Saved Password Editor
Version: 2.8.3
Enabled: true
ID: savedpasswordeditor@daniel.dawson

Name: Send Tab to Device
Version: 0.6
Enabled: true
ID: jid1-mdjmA7if6lo8lA@jetpack

Name: Stylish
Version: 2.0.1
Enabled: true
ID: {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}

Name: Stylish Sync
Version: 0.1.7
Enabled: true
ID: {0e3fc079-afbb-4a00-87e5-9486062d0f9c}

Name: Tumblr Post
Version: 1.36
Enabled: true
ID: {99210d54-6321-41e8-bd1b-2b4c55874efb}

Name: Ubuntu Firefox Modifications
Version: 3.0
Enabled: true
ID: ubufox@ubuntu.com

Name: Image Zoom
Version: 0.6.3
Enabled: false
ID: {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}

Name: Mozilla Labs: Prospector - about:profile
Version: 3
Enabled: false
ID: aboutProfile@prospector.labs.mozilla

Name: PDF Viewer
Version: 1.0.277
Enabled: false
ID: uriloader@pdf.js

Name: Test Pilot
Version: 1.2.3
Enabled: false
ID: testpilot@labs.mozilla.com

Name: Ubuntu Online Accounts
Version: 0.5
Enabled: false
ID: online-accounts@lists.launchpad.net

Name: Unity Desktop Integration
Version: 3.0.2
Enabled: false
ID: webapps-team@lists.launchpad.net

Name: Unity Websites integration
Version: 2014.07.01.beta
Enabled: false
ID: {2e1445b0-2682-11e1-bfc2-0800200c9a66}

Graphics
--------

Adapter Description: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
Device ID: Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
Driver Version: 2.1 Mesa 10.3.2
GPU Accelerated Windows: 0/1 Basic
Vendor ID: Intel Open Source Technology Center
WebGL Renderer: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150204150234
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20150204150234
browser.startup.homepage_override.mstone: 38.0a1
browser.tabs.remote.autostart.1: false
browser.urlbar.default.behavior: 0
dom.max_chrome_script_run_time: 40
dom.max_script_run_time: 40
dom.mozApps.used: true
extensions.lastAppVersion: 38.0a1
media.gmp-gmpopenh264.enabled: false
media.gmp-gmpopenh264.lastUpdate: 1422794071
media.gmp-gmpopenh264.path: /home/sabret00the/.mozilla/firefox-trunk/sgsp2inn.default/gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.3
media.gmp-manager.lastCheck: 1420724975
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1423847806
places.history.expiration.transient_current_max_pages: 45922
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.librhythmbox-itms-detection-plugin: 0
plugin.state.libtotem-gmp-plugin: 0
plugin.state.libtotem-mully-plugin: 0
plugin.state.libtotem-narrowspace-plugin: 0
privacy.donottrackheader.enabled: true
privacy.donottrackheader.value: 1
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.brief.sqlite: 1410965568
storage.vacuum.last.index: 2
storage.vacuum.last.places.sqlite: 1421625841

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSMIME
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSSL
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSUTIL
Expected minimum version: 3.17.4
Version in use: 3.17.4

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Media Plugin Sandboxing: true
Flags: needinfo?(pwd.mozilla)
Blocks: 904346
Sorry for not getting back to this earlier. I tested and couldn't reproduce the issue :(

I think it makes sense to get back to this once bug 558184. Shumway will be activated in a pretty different way at that point, so investigating issues around the way it's activated (or deactivated) right now wouldn't be all that useful.
(Reporter)

Comment 6

2 years ago
No worries. I'll mark invalid and re-file if there's still an issue after bug 558184 lands
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Assignee)

Updated

a year ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.