[Windows Management] [Notifications] Notifications are unable to or difficult to scroll on the notification menu.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: cwiiis)

Tracking

({regression})

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 attachments)

Reporter

Description

4 years ago
Description:
When notifications exceed the size of the notification menu the user is able to scroll to see them. Currently the notifications are difficult to scroll. It is often unresponsive but will occasionally work. When it does work you can scroll up and down until you lift your finger, and then it 'resets' and may not scroll again.

Repro Steps:
1) Update a Flame to 20150213010213
2) Fill up your notification menu (screenshots work great for this)
3) Pull down the notification bar to access the notification menu
4) Attempt to scroll the notifications

Actual:
Notification menu difficult to scroll / sometimes unresponsive

Expected:
Menu will always be responsive and scrollable

Environmental Variables:
Device: Flame 3.0
Build ID: 20150213010213
Gaia: 2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko: 2f5c5ec1a24b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 7/9
See attached: logcat
------------------------------------------------------------------

This issues does NOT repro in 2.2

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150213002503
Gaia: ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko: d04b78eeb536
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Performance regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
QA Contact: ychung
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150211190942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150211230942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ed69c4d2c15&tochange=07479758ab68

caused by bug 1127066
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Botond, here is another issue that is pointing to the same bug 1127066
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Depends on: 1127066
Flags: needinfo?(ktucker) → needinfo?(botond)
Blocks: 1127066
No longer depends on: 1127066
This is a Gaia bug; the code at [1] is causing the pan attempts to get killed. This was exposed by bug 1127066 because before that we weren't properly respecting preventDefault() on the first touchmove event, but now we are.

Chris, as you seem to have been the last one to touch the code in question, mind taking a look at this?

[1] https://github.com/mozilla-b2g/gaia/blob/404bbb2cefb34241e0e4aa1b1fea2ddd51c0d7bc/apps/system/js/notifications.js#L265
Flags: needinfo?(botond) → needinfo?(chrislord.net)
Note that this will affect 2.2 as well since bug 1127066 has been uplifted there (very recently, which is probably it didn't show up in the branch checks).
blocking-b2g: 3.0? → 2.2?
Assignee

Comment 6

4 years ago
Taking.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
Assignee

Updated

4 years ago
Attachment #8566039 - Flags: review?(mhenretty)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Comment on attachment 8566039 [details] [review]
[gaia] Cwiiis:bug1132967-scroll-notifications > mozilla-b2g:master

Works like a charm!
Attachment #8566039 - Flags: review?(mhenretty) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Assignee

Comment 10

4 years ago
Merged manually: https://github.com/mozilla-b2g/gaia/commit/9b19f34c88239160001b87472f5966e9885889a4
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 11

4 years ago
Comment on attachment 8566039 [details] [review]
[gaia] Cwiiis:bug1132967-scroll-notifications > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Can't scroll utility tray when there are many notifications
[Testing completed]: Tested manually
[Risk to taking this patch] (and alternatives if risky): No risk, minimal change
[String changes made]: None
Attachment #8566039 - Flags: approval-gaia-v2.2?
blocking-b2g: 2.2? → 2.2+
Attachment #8566039 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Assignee

Updated

4 years ago
Duplicate of this bug: 816361
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.  
	
Actual Results: Notifications are easily scrolled through.

Environmental Variables:
Device: Flame 3.0 KK (319MB)(Full Flash)
BuildID: 20150225010244
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: 0a8b3b67715a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319MB)(Full Flash)
BuildID: 20150225002505
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Gecko: 16804008c29f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.