White line above name of searchengine (e.g. Google) in rocketbar/searchbar results section for search suggestions

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: daleharvey)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments, 1 obsolete attachment)

B2G 2.2 20150214002504 on Flame (v188 base image)

There is a white line above the name of the search engine (e.g. Google) in the rocketbar results section for search suggestions (which are disabled).

Can't reproduce on Geeksphone Keon with B2G 3.0 20150214014859.
does this still reproduce?
blocking-b2g: --- → 2.2?
Keywords: qawanted
Yes, still see this with B2G 3.0 20150219160225 on Flame (v188 base image).
Whiteboard: [systemsfe]
This issue reproduces on Flame 2.2. In addition to comment 0's behavior, bug 1134742 is also observed. See screenshot on what I'm seeing.

Device: Flame 2.2 (shallow flash 319MB)
BuildID: 20150220073201
Gaia: 2b694a5a332495f1b9db06253690a2f5a702ed80
Gecko: 5c20fbeb5f8b
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0 Master (shallow flash 319MB)
BuildID: 20150220061649
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 5f1009731a97
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Not checking 2.1 since this refactor of rocketbar search is not implemented.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Assignee: nobody → dale
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 5

4 years ago
Comment on attachment 8568511 [details] [review]
[gaia] daleharvey:1133202 > mozilla-b2g:master

Just puts the select box offscreen, its impossible to actually hide (display: none / visibility: hidden) etc since if its not display then it cant be triggered

Testing this isnt easy since the 'displayed()' logic is the same as whats needed to trigger it (it needs displayed() === true) or it wont trigger, so I left a test out, its CSS only anyway.
Attachment #8568511 - Flags: review?(kgrandon)
Comment on attachment 8568511 [details] [review]
[gaia] daleharvey:1133202 > mozilla-b2g:master

Left a comment on github. I would prefer an opacity change I think as it feels less hack-ish to me. If there is a good reason to go with this over opacity then that would work for me. Thanks.
Attachment #8568511 - Flags: review?(kgrandon) → review+
(Assignee)

Comment 7

4 years ago
Good call, I didnt think of opacity, thats cleaner and landed with

https://github.com/mozilla-b2g/gaia/commit/7cf43cd4ec81882564c75f522977b0f68d6d71a8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1136430
(Assignee)

Comment 11

4 years ago
Switched opacity to .1 and kept the height / width changes, carrying review, Green Gij run @ https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=35b76c4d5f2f

Landed in https://github.com/mozilla-b2g/gaia/commit/9595dac56dc47f458a8567d8db099900d574e914
(Assignee)

Comment 12

4 years ago
Comment on attachment 8569081 [details] [review]
[gaia] daleharvey:1133202-redux > mozilla-b2g:master

Carrying review from other PR
Attachment #8569081 - Flags: review+
(Assignee)

Comment 13

4 years ago
Comment on attachment 8568511 [details] [review]
[gaia] daleharvey:1133202 > mozilla-b2g:master

Marking obselete to be less confusing
Attachment #8568511 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Hmm, was the opacity 0.1 just a fix for a test that is checking the visibility? It doesn't seem like the *correct* fix to me to be honest. Seems like we might need a follow-up here to investigate.
Depends on: 1136722
(Assignee)

Comment 15

4 years ago
Yeh locally it triggered fine but on travis opacity 0 prevented the select from being triggered, the select now has a hight and width of 0, opacity 0.1 and is placed behind the label so it should be impossible to see but still be triggerable, hopefully should be enough
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(dale)
Target Milestone: --- → 2.2 S7 (6mar)
(Assignee)

Comment 17

4 years ago
Comment on attachment 8569081 [details] [review]
[gaia] daleharvey:1133202-redux > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New feature dev
[User impact] if declined: Little
[Testing completed]: Manually verified, configuration change
[Risk to taking this patch] (and alternatives if risky): Very little, config change
[String changes made]:
Flags: needinfo?(dale)
Attachment #8569081 - Flags: approval-gaia-v2.2?
Attachment #8569081 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: A white line is not visible above the name of any of the search engines.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150313010238
Gaia: eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gecko: 42afc7ef5ccb
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150313002507
Gaia: 4aefc3f6f30a40ac67fdf841b7c90cd648b85369
Gecko: 049713f3b0ed
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Per comment 19, clear verifyme keyword.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.