[Search] Dropdown icon is mislocated

VERIFIED WORKSFORME

Status

defect
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: nefzaoui)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted image DropDownSymbol.png
Description:
The blue triangle symbol that indicates a dropdown menu overlaps with the search name string on the rocket bar search result screen.

Repro Steps:
1) Update a Flame to 20150219010228
2) Tap the rocket bar on the homescreen, and enter any letter.
3) Observe "GOOGLE SEARCH" text on the search result screen.

Actual:
Dropdown symbol overlaps with the text.

Expected:
Dropdown symbol does not overlap and located on the right side of the string.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.2.

Result: The dropdown symbol overlaps with the text.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

4 years ago
This issue might be related to RTL. When the device is set in Arabic, the blue triangle does NOT appear at all on the search screen.
This looks pretty bad and the drop down arrow is completely missing when using a RTL language. Hermes, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(hcheng)
Duplicate of this bug: 1134763
Transferred information from dupe: 
Issue is a recent regression and was working as recently as 20150209010211 on 3.0 (see screenshot)
Keywords: regression
blocking-b2g: --- → 2.2?
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
blocking-b2g: 2.2? → 2.2+
Seems this was caused by bug 1129701.
Blocks: 1129701
Fixed by backing out bug 1129701.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
clear the ni for me. leave this bug non-verified until the pvt build having the backing out search.css.
Flags: needinfo?(hcheng)
Resolution: FIXED → WORKSFORME
* It is ok now on 2.2
Build ID               20150225162504
Gaia Revision          e4bf968d5a7366e7bdc58f0fdba28b32e864bdf7
Gaia Date              2015-02-25 18:39:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/da6ac51f5113
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.200419
Firmware Date          Wed Feb 25 20:04:31 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
add verifyme for master branch
Keywords: verifyme
Posted image screenshot
This problem is verified pass on latest build of Flame 3.0.
STR:
1. Set system language to Arabic.
2. Tap the rocket bar on the homescreen, and enter any letter.
** The blue triangle icon display normally and located on the right side of the "GOOGLE SEARCH" string.
3. Set system language back to English.
4. Tap the rocket bar again, and enter any letter.
** The blue triangle icon display normally and located on the right side of the "GOOGLE SEARCH" string too.
See attachment: Verify_screenshot.PNG
Fail rate: 0/5

Flame 3.0 build:
Build ID               20150302010223
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.043726
Firmware Date          Mon Mar  2 04:37:37 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
Assignee: nobody → nefzaoui
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.