(SeaMonkey) Moving emails from Search Box Results to other folders creates duplicate emails and/or phantom mail, because oncommand is placed in <menupopup type="folder"> instead of in container <menu> of the menupopup

RESOLVED FIXED in seamonkey2.36

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philip.chee, Assigned: philip.chee)

Tracking

Trunk
seamonkey2.36
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.33 wontfix, seamonkey2.34 wontfix, seamonkey2.35 fixed, seamonkey2.36 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
(In reply to neil@parkwaycc.co.uk from Bug 1001071 comment #14)
> This caused bug 1106225 for SeaMonkey because you moved the oncommand from
> the button to the menupopup where it gets duplicated throughout the folder
> menu and fires multiple times.

(In reply to WADA from Bug 1106225 comment #21)
> Minimum required change for this bug
>  
> http://mxr.mozilla.org/comm-central/source/mail/base/content/SearchDialog.
> xul#183
>                183  <button id="fileMessageButton" type="menu"
> label="&moveButton.label;"
>   Add                       oncommand="MoveMessageInSearch(event.target) 
>                184          accesskey="&moveButton.accesskey;"
>                185          observes="file_message_button">
>   Change 186    <menupopup type="folder" showFileHereLabel="true"
> mode="filing"   />
>   Delete   187    ...
>                188  </button>
>
Assignee

Comment 1

4 years ago
Attachment #8564745 - Flags: review?(neil)
Attachment #8564745 - Flags: review?(neil) → review+
Assignee

Comment 2

4 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/85c52bd62394
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.36
Assignee

Comment 3

4 years ago
Comment on attachment 8564745 [details] [diff] [review]
Patch v1 move oncommand back to button

[Approval Request Comment]
Regression caused by (bug #): Bug 1001071
User impact if declined: Moving emails from Search Box Results to other folders creates duplicate emails and/or phantom mail
Testing completed (on m-c, etc.): tested and baked on 2.36
Risk to taking this patch (and alternatives if risky): none bustage fix.
String changes made by this patch: None.
Attachment #8564745 - Flags: approval-comm-release?
Assignee

Updated

4 years ago
Assignee

Comment 4

4 years ago
(In reply to Philip Chee from comment #3)
> Comment on attachment 8564745 [details] [diff] [review]
> Patch v1 move oncommand back to button
> 
> [Approval Request Comment]
> Regression caused by (bug #): Bug 1001071
> User impact if declined: Moving emails from Search Box Results to other
> folders creates duplicate emails and/or phantom mail
> Testing completed (on m-c, etc.): tested and baked on 2.36
> Risk to taking this patch (and alternatives if risky): none bustage fix.
> String changes made by this patch: None.

Flags: approval-comm-release?
Flags: needinfo?(iann_bugzilla)

Updated

4 years ago
Flags: needinfo?(iann_bugzilla)
Attachment #8564745 - Flags: approval-comm-release? → approval-comm-release+
You need to log in before you can comment on or make changes to this bug.