Bug 1177041 (SM2.35-Uplift)

Bugs / Patches to be uplifted to comm-release for SeaMonkey 2.35

RESOLVED FIXED in seamonkey2.35

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: philip.chee, Unassigned)

Tracking

({meta})

SeaMonkey 2.35 Branch
seamonkey2.35
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.35+ fixed)

Details

User Story

Bug 1177702, crash in EncodedHeader from incorrectly encoded UTF8 in header

Bug 837552   crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters
Bug 893776   Placeholders instead of pictures shown in newsgroup posting bodies
Bug 1072751  Switch SeaMonkey from xpinstall.whitelist.add to using a default permissions file
Bug 1122906  First right-click on textarea shows huge contextmenu
Bug 1133212  (SeaMonkey) Moving emails from Search Box Results to other folders creates duplicate emails and/or phantom mail, because oncommand is placed in <menupopup type="folder"> instead of in container <menu> of the menupopup
Bug 1135604  Add MOZ_SAFE_BROWSING to confvars.sh and minor updates
Bug 1147456  "View -> Page Info: Copy any information from list does not modify clipboard
Bug 1156088  Doorhangers display useless "Learn more..." link when using the Modern theme
Bug 1160565  Package FormAutofillStartup.js
Bug 1163395  Port Bug 967494 to SeaMonkey (Preference Composition/Spelling/Language is ignored, and changing spellcheck language in one composition window affects all open and new compositions)
Bug 1165612  Port Thunderbird Bug 1130248 (Allow email addresses in address name fields)
Bug 1170002  Display-name with comma in it does not get properly quoted in From: field
Bug 1174159  Thunderbird 38.0.1: cannot send email through exchange server (NTLM)
  http://hg.mozilla.org/releases/comm-esr38/rev/a2c209b23910
Bug 1174528  Bookmarks sidebar panel is empty in non-browser windows
Bug 1175190 - Thunderbird 38 crashes in mozilla::mailnews::EncodedHeader [msvcr120.dll | nsCOMArray_base::Adopt | mozilla::mailnews::EncodedHeader]
Bug 1175348  oauth related crash in nsMsgAsyncWriteProtocol::SendData(char const*, bool)
  http://hg.mozilla.org/releases/comm-esr38/rev/5e4b9696b493
Bug 1176602  In message compose make sure that the dictionary stored in spellchecker.dictionary is valid (Adapt Thunderbird Bug 1175908)
Bug 1176671  Changing dictionary language from spellcheck dialogue is not persisted after closing the dialogue
Bug 1176773  Support imap.gmail.com and smtp.gmail.com urls in OAuth2
 https://hg.mozilla.org/releases/comm-esr38/rev/cf109c971a2e
Bug 1178413  GMail OAuth2 scope should be https:// not http://
  https://hg.mozilla.org/releases/comm-esr38/rev/1ee92a3094fa

Bug 1132478 - Feed Reader sends wrong Accept header
http://hg.mozilla.org/releases/comm-esr38/rev/04a14456d206
Bug 1151448 - Cross-posts won't send because Newsgroups: groups are separated with comma+space, not just comma
http://hg.mozilla.org/releases/comm-esr38/rev/1db4c5ee3045

Bug 1190233 - "Default" permissions being added to an existing profile without user's consent or awareness

Attachments

(4 attachments)

Comment hidden (empty)
(Reporter)

Updated

4 years ago
Depends on: 1072751
(Reporter)

Updated

4 years ago
Depends on: 1135604
(Reporter)

Updated

4 years ago
Depends on: 1147456
(Reporter)

Updated

4 years ago
Depends on: 1122906
(Reporter)

Updated

4 years ago
Depends on: 1174528
(Reporter)

Updated

4 years ago
Depends on: 1163395
(Reporter)

Updated

4 years ago
Depends on: 1176671
(Reporter)

Comment 1

4 years ago
Bug 837552 - crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters
Bug 1177702, crash in EncodedHeader from incorrectly encoded UTF8 in header
Depends on: 837552
(Reporter)

Updated

4 years ago
User Story: (updated)
(Reporter)

Updated

4 years ago
User Story: (updated)
Depends on: 1176773, 1178413
(Reporter)

Updated

4 years ago
User Story: (updated)
Depends on: 1174159
(Reporter)

Updated

4 years ago
Depends on: 1180911
(Reporter)

Updated

4 years ago
User Story: (updated)
(Reporter)

Updated

4 years ago
User Story: (updated)
(Reporter)

Updated

4 years ago
Depends on: 1175190
(Reporter)

Comment 2

4 years ago
Created attachment 8632851 [details] [diff] [review]
Bug 837552, crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters
Testing completed (on m-c, etc.): Tested with Thunderbird esr38, 40, 41, 42
Risk to taking this patch (and alternatives if risky): none, just adds a null check.
String changes made by this patch: none.
Attachment #8632851 - Flags: approval-comm-release?

Comment 3

4 years ago
Comment on attachment 8632851 [details] [diff] [review]
Bug 837552, crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters

Is this for 2.36 as isn't it already on ESR38?
Attachment #8632851 - Flags: approval-comm-release? → approval-comm-release+
(Reporter)

Updated

4 years ago
Depends on: 1175348
(Reporter)

Updated

4 years ago
User Story: (updated)
(Reporter)

Comment 4

4 years ago
(In reply to Ian Neal from comment #3)
> Bug 837552, crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters
> Is this for 2.36 as isn't it already on ESR38?
Yes it's on comm-esr38, but we are building off comm-release+SEAMONKEY_2_35_RELEASE_BRANCH
For the mozilla- part we are going to use mozilla-esr38 to pick up the latest security patches.

Bug 837552 has the following status:
> status-thunderbird39: wontfix
> status-thunderbird40: fixed
> status-thunderbird41: fixed
> status-thunderbird42: fixed
> status-thunderbird_esr38: fixed
(Reporter)

Updated

4 years ago
Depends on: 1183198
(Reporter)

Updated

4 years ago
Depends on: 1172559
(Reporter)

Updated

4 years ago
Depends on: 1183275
(Reporter)

Updated

4 years ago
Depends on: 1183290
(Reporter)

Comment 5

4 years ago
Created attachment 8632973 [details]
A list of bugs with approval-comm-release? requested for SeaMonkey 2.35
a=iann_bugzilla

comm-release-seamonkey-2.35
===========================

Bug 1163395 - Port Bug 967494 to SeaMonkey (Preference Composition/Spelling/Language is ignored, and changing spellcheck language in one composition window affects all open and new compositions)
http://hg.mozilla.org/comm-central/rev/0979b9fca097
NOTE: corresponding mozilla patch landed on mozilla-esr38
http://hg.mozilla.org/releases/mozilla-esr38/rev/3c181756da20
approval-comm-release?

Bug 1165612 - Port Thunderbird Bug 1130248 (Allow email addresses in address name fields)
http://hg.mozilla.org/comm-central/rev/7636eb8e94b6
approval-comm-release?

Bug 1174159 - thunderbird 38.0.1: cannot send email through exchange server (NTLM)
http://hg.mozilla.org/releases/comm-esr38/rev/a2c209b23910
approval-comm-release?

Bug 1183275 - Take patches from Bug 1175190 and Bug 1177702 for SeaMonkey 2.35 to fix crashes in EncodedHeader
approval-comm-release?
  Bug 1175190 - Thunderbird 38 crashes in mozilla::mailnews::EncodedHeader [msvcr120.dll | nsCOMArray_base::Adopt | mozilla::mailnews::EncodedHeader]
  http://hg.mozilla.org/releases/comm-esr38/rev/e7bcc03ba8b1
  Bug 1177702, crash in EncodedHeader from incorrectly encoded UTF8 in heade

Bug 1183290 - Take patch from Bug 1176671 (Change lang attribute when dictionary is changed) for SeaMonkey 2.35
approval-comm-release?
  Bug 1176671 - Changing dictionary language from spellcheck dialogue is not persisted after closing the dialogue.
  http://hg.mozilla.org/releases/comm-esr38/rev/8d5d97576d43

Bug 1183198 - Take Gmail OAuth2 mailnews patches from Bug 1178413 and Bug 1176773 for comm-release SeaMonkey 2.35
approval-comm-release?
NOTE: Following two patches should be landed together.
  Bug 1176773 - OAuth2 does not work with imap.gmail.com after upgrade
  https://hg.mozilla.org/releases/comm-esr38/rev/cf109c971a2e
  Bug 1178413 - GMail OAuth2 scope should be https:// not http://.
  https://hg.mozilla.org/releases/comm-esr38/rev/1ee92a3094fa
Flags: needinfo?(iann_bugzilla)
(Reporter)

Updated

4 years ago
Depends on: 1178008

Comment 6

4 years ago
(In reply to Philip Chee from comment #5)
> comm-release-seamonkey-2.35
> ===========================
> 
> Bug 1174159 - thunderbird 38.0.1: cannot send email through exchange server
> (NTLM)
> http://hg.mozilla.org/releases/comm-esr38/rev/a2c209b23910
> approval-comm-release?
This requires mailnews approval which I cannot give.

Rest are done.
Flags: needinfo?(iann_bugzilla)
(Reporter)

Comment 7

4 years ago
Created attachment 8634894 [details]
Uplift MailNews Bug 1175348 Bug 1174159 to comm-release+SEAMONKEY_2_35_RELEASE_BRANCH

(In reply to Ian Neal from comment #6)
> (In reply to Philip Chee from comment #5)
>> comm-release-seamonkey-2.35
>> ===========================
>> 
>> Bug 1174159 - thunderbird 38.0.1: cannot send email through exchange server
>> (NTLM)
>> http://hg.mozilla.org/releases/comm-esr38/rev/a2c209b23910
>> approval-comm-release?
> This requires mailnews approval which I cannot give.

Please consider uplift to comm-release+SEAMONKEY_2_35_RELEASE_BRANCH

Bug 1174159 - thunderbird 38.0.1: cannot send email through exchange server (NTLM)
http://hg.mozilla.org/releases/comm-esr38/rev/a2c209b23910

Bug 1175348 - oauth related crash in nsMsgAsyncWriteProtocol::SendData(char const*, bool)
http://hg.mozilla.org/releases/comm-esr38/rev/5e4b9696b493
Flags: needinfo?(iann_bugzilla)
Attachment #8634894 - Flags: approval-comm-release?

Updated

4 years ago
Flags: needinfo?(iann_bugzilla)
Attachment #8634894 - Flags: approval-comm-release? → approval-comm-release+
(Reporter)

Updated

4 years ago
Attachment #8632973 - Attachment description: A list of bugs with approval-comm-release? requested for SeaMonkey 2.35 → A list of bugs with approval-comm-release? requested for SeaMonkey 2.35 a=iann_bugzilla
Attachment #8632973 - Flags: approval-comm-release+
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.35: --- → fixed
tracking-seamonkey2.35: --- → +
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.35
(Reporter)

Comment 8

3 years ago
I missed two:
Bug 1132478 - Feed Reader sends wrong Accept header
http://hg.mozilla.org/releases/comm-esr38/rev/04a14456d206
Bug 1151448 - Cross-posts won't send because Newsgroups: groups are separated with comma+space, not just comma
http://hg.mozilla.org/releases/comm-esr38/rev/1db4c5ee3045
Status: RESOLVED → REOPENED
User Story: (updated)
Depends on: 1132478, 1151448
Resolution: FIXED → ---
(Reporter)

Comment 9

3 years ago
Created attachment 8636533 [details]
Uplift MailNews Bug 1132478 Bug 1151448 to comm-release+SEAMONKEY_2_35_RELEASE_BRANCH a=IanN_bugzilla

Bug 1132478 - Feed Reader sends wrong Accept header
http://hg.mozilla.org/releases/comm-release/rev/da4fcbb68d85 

Bug 1151448 - Cross-posts won't send because Newsgroups: groups are separated with comma+space, not just comma
Bug 1151448 http://hg.mozilla.org/releases/comm-release/rev/fd8425db2bfe
Attachment #8636533 - Flags: approval-comm-release+
(Reporter)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED

Comment 10

3 years ago
Late arrival: Bug 1190233 - "Default" permissions being added to an existing profile without user's consent or awareness - got approval to land on SEAMONKEY_2_35_RELEASE_BRANCH.
Depends on: 1190233
(Reporter)

Comment 11

3 years ago
(Commenting on User Story)
> Bug 1177702, crash in EncodedHeader from incorrectly encoded UTF8 in header
> 
> Bug 837552   crash in nsMsgDatabase::CopyHdrFromExistingHdr with filters
> Bug 893776   Placeholders instead of pictures shown in newsgroup posting
> bodies
> Bug 1072751  Switch SeaMonkey from xpinstall.whitelist.add to using a
> default permissions file
> Bug 1122906  First right-click on textarea shows huge contextmenu
> Bug 1133212  (SeaMonkey) Moving emails from Search Box Results to other
> folders creates duplicate emails and/or phantom mail, because oncommand is
> placed in <menupopup type="folder"> instead of in container <menu> of the
> menupopup
> Bug 1135604  Add MOZ_SAFE_BROWSING to confvars.sh and minor updates
> Bug 1147456  "View -> Page Info: Copy any information from list does not
> modify clipboard
> Bug 1156088  Doorhangers display useless "Learn more..." link when using the
> Modern theme
> Bug 1160565  Package FormAutofillStartup.js
> Bug 1163395  Port Bug 967494 to SeaMonkey (Preference
> Composition/Spelling/Language is ignored, and changing spellcheck language
> in one composition window affects all open and new compositions)
> Bug 1165612  Port Thunderbird Bug 1130248 (Allow email addresses in address
> name fields)
> Bug 1170002  Display-name with comma in it does not get properly quoted in
> From: field
> Bug 1174159  Thunderbird 38.0.1: cannot send email through exchange server
> (NTLM)
>   http://hg.mozilla.org/releases/comm-esr38/rev/a2c209b23910
> Bug 1174528  Bookmarks sidebar panel is empty in non-browser windows
> Bug 1175190 - Thunderbird 38 crashes in mozilla::mailnews::EncodedHeader
> [msvcr120.dll | nsCOMArray_base::Adopt | mozilla::mailnews::EncodedHeader]
> Bug 1175348  oauth related crash in nsMsgAsyncWriteProtocol::SendData(char
> const*, bool)
>   http://hg.mozilla.org/releases/comm-esr38/rev/5e4b9696b493
> Bug 1176602  In message compose make sure that the dictionary stored in
> spellchecker.dictionary is valid (Adapt Thunderbird Bug 1175908)
> Bug 1176671  Changing dictionary language from spellcheck dialogue is not
> persisted after closing the dialogue
> Bug 1176773  Support imap.gmail.com and smtp.gmail.com urls in OAuth2
>  https://hg.mozilla.org/releases/comm-esr38/rev/cf109c971a2e
> Bug 1178413  GMail OAuth2 scope should be https:// not http://
>   https://hg.mozilla.org/releases/comm-esr38/rev/1ee92a3094fa
> 
> Bug 1132478 - Feed Reader sends wrong Accept header
> http://hg.mozilla.org/releases/comm-esr38/rev/04a14456d206
> Bug 1151448 - Cross-posts won't send because Newsgroups: groups are
> separated with comma+space, not just comma
> http://hg.mozilla.org/releases/comm-esr38/rev/1db4c5ee3045

Bug 1190233 - "Default" permissions being added to an existing profile without user's consent or awareness
(Reporter)

Comment 12

3 years ago
oops.
Status: RESOLVED → REOPENED
User Story: (updated)
Resolution: FIXED → ---
(Reporter)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.