Firefox 36beta7, 36beta8, 36beta9 comes with two copies of gcc-4.7 in source tarball

RESOLVED DUPLICATE of bug 1136240

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1136240
3 years ago
3 years ago

People

(Reporter: Maxim Britov, Unassigned)

Tracking

36 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Firefox 36beta7, 36beta8, 36beta9 comes with two copies gcc-4.7 in source tarball.
In result size grow from ~170MB in beta6 to ~390MB in beta7,beta8,beta9

$ tar xjf /usr/portage/distfiles/firefox-36.0b9.source.tar.bz2

$ ls -l mozilla-beta/gcc.tar.xz 
-rw------- 1 root root 80458572 Feb 13 03:03 mozilla-beta/gcc.tar.xz

$ du -hs mozilla-beta/gcc/
433M	mozilla-beta/gcc/

$ ./mozilla-beta/gcc/bin/gcc -v
Using built-in specs.
COLLECT_GCC=./mozilla-beta/gcc/bin/gcc
COLLECT_LTO_WRAPPER=/root/111/mozilla-beta/gcc/bin/../libexec/gcc/x86_64-unknown-linux-gnu/4.7.3/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: ../gcc-4.7.3/configure --prefix=/tools/gcc --enable-languages=c,c++ --disable-nls --disable-gnu-unique-object --enable-__cxa_atexit --with-arch-32=pentiumpro
Thread model: posix
gcc version 4.7.3 (GCC)
Component: General → Build Config
Product: Firefox → Core
(Reporter)

Comment 1

3 years ago
+ thunderbird-36.0b1.source.tar.bz2 424045479 bytes
also two copies of gcc-4.7.3
(Reporter)

Comment 2

3 years ago
heh...
+ Firefox 31.5.0esr, Firefox 36.0, Firefox 37.0beta1, Thunderbird 31.5.0

Seems it nobody cares in mozilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136240
You need to log in before you can comment on or make changes to this bug.