TelemetryEnvironment: check |activeGMPlugins| test coverage.

RESOLVED FIXED

Status

()

P4
normal
RESOLVED FIXED
4 years ago
4 months ago

People

(Reporter: Dexter, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [measurement:client])

(Reporter)

Description

4 years ago
We need |activeGMP| test coverage in test_TelemetryEnvironment.js.

test_openh264.js (soon test_gmpProvider.js?) shows how to fake them.
(Reporter)

Updated

4 years ago
Blocks: 1120356
Blocks: 1137262
No longer blocks: 1120356
Per bug 1203159 the GMPProvider will already get instantiated in test_TelemetryEnvironment.js, but the version data may be null.
We should figure out whats going on there.
Points: --- → 1
Depends on: 1203159
Priority: -- → P3
Summary: TelemetryEnvironment: add |activeGMPlugins| test coverage. → TelemetryEnvironment: check |activeGMPlugins| test coverage.
Whiteboard: [measurement:client]
Duplicate of this bug: 1136714
Per bug 1136714 we should also see that the test-coverage for this is activated on Android again.
(Reporter)

Comment 4

3 years ago
We should also change [0] from |if (!plugin.isGMPlugin)| to |if (!plugin.isGMPlugin || !plugin.isValid)|.

[0] - https://dxr.mozilla.org/mozilla-central/rev/f029ccdee154bdc2b49a1e0fcd5b0fa0397aa97b/toolkit/components/telemetry/TelemetryEnvironment.jsm#624
(Reporter)

Comment 5

3 years ago
Please ignore comment 4, as plugin.isValid is not available from the GMPlugin wrapper.
Priority: P3 → P4
Component: Client: Desktop → Telemetry
Product: Firefox Health Report → Toolkit

Comment 6

4 months ago
It appears as though we have added test coverage for the structure of activeGMP in test_TelemetryEnvironment.js
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.