jwplayer - The UI progress bar overlaps menu buttons

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: yury, Assigned: tschneider)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Dependency tree / graph

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The UI progress bar overlaps everything in the pop up menu.

The first bad revision is:
changeset:   228180:9ddd307bb5d1
user:        Tooru Fujisawa <arai_a@mac.com>
date:        Tue Feb 10 02:04:30 2015 +0900
summary:     Bug 1120169 - Implement RegExp.prototype.{global, ignoreCase, multiline, source, sticky, unicode}. r=till
(Reporter)

Updated

4 years ago
Summary: jwplayer UI regressed → jwplayer - The UI progress bar overlaps menu buttons
Created attachment 8564861 [details] [diff] [review]
(test) Revert RegExp.prototype.source.

Seems to be a trouble related to RegExp.prototype.source.
Applying this patch fixes the issue.
in shumway.player.js:15404
http://areweflashyet.com/shumway/build/bundles/shumway.player.js
>                regex = augment(new RegExp(regex.source, flags), hasNamedCapture(regex) ? regex[REGEX_DATA].captureNames.slice(0) : null, options.addProto);

`regex.source` returns `undefined` (other flags are also `undefined`), because the there is no source getter in prototype chain.
https://github.com/mozilla/shumway/pull/2081

Also, there should be related behavior differences in `source`, caused by bug 1130860 and bug 1130798.
  new RegExp("", "").source
  new RegExp("\r\n", "").source
  new RegExp("\u2028\u2029").source
Assignee: nobody → schneider
Depends on: 1118980
(Assignee)

Comment 4

4 years ago
Fixed by https://github.com/mozilla/shumway/pull/2081.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.