[Flame][Homescreen]The next card will be cut half off when closing one app in card view.

RESOLVED DUPLICATE of bug 1132980

Status

()

defect
RESOLVED DUPLICATE of bug 1132980
4 years ago
4 years ago

People

(Reporter: liuyong, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 unaffected, b2g-master affected)

Details

Attachments

(2 attachments)

106.14 KB, text/plain
Details
964.69 KB, video/mp4
Details
(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v3.0][Homescreen]In card view, close one app, the next card will be cut half off for a moment.
Attachment: Cardview.mp4,logcat_1540.txt
Found time:15:40

[2.Testing Steps]: 
1. Launch more than two apps.
2. Long press home key, switch to card view.
3. Silde card to close an APP, check the next card.

[3.Expected Result]: 
3. The app card should be displayed completely.

[4.Actual Result]: 
3. The next card will  be cut half off.

[5.Reproduction build]: 
Build ID               20150215010209
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.043133
Firmware Date          Sun Feb 15 04:31:43 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]:
Free test
(Reporter)

Comment 1

4 years ago
Posted file logcat_1540.txt
(Reporter)

Comment 2

4 years ago
Posted video Cardview.MP4
Sam, is this us or the gfx team?
Flags: needinfo?(sfoster)
Looks like gfx. We do a little trickery(1) in the transition to account for the fact the off-screen cards aren't actually offscreen, but the adjacent card seen in the video is visible, has its expected width/height and is simply translateX() to position it and animate it into the vacated slot.  

1. https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/task_manager.js#L918,L921
Flags: needinfo?(sfoster)
Kats, can you move this to the right component?
Flags: needinfo?(bugmail.mozilla)
blocking-b2g: --- → 2.2?
Blocks: 1134202
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: Gaia::Homescreen → Graphics: Layers
Flags: needinfo?(bugmail.mozilla)
Product: Firefox OS → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1132980

Updated

4 years ago
Keywords: regression
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.