Warning box in about:config doesn't display properly in Modern any more

RESOLVED FIXED in seamonkey2.36

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rsx11m.pub, Assigned: neil)

Tracking

(Blocks 1 bug, {regression})

Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.34 unaffected, seamonkey2.35 fixed, seamonkey2.36 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1133380 +++

Bug 1125636 changed the theming of about:config in Toolkit, now it's broken in the Modern theme for which config.css needs to be adjusted. Specifically, the box width appears to be no longer constrained, and the warning icon is missing, possibly other issues.

Also, that bug introduced chrome://global/skin/in-content/info-pages.css which we don't have in Modern (no warning is thrown in the error console).
Assignee

Comment 1

4 years ago
Posted patch Proposed patch (obsolete) — Splinter Review
* Moved the max-width from the warningInnerBox to the title/description
* Moved the image from #exclam to the background of the warningBox
* Set the background position of the image to the old padding
* Increased the left padding by the width of the image
* Moved the image's right padding to left padding on the title/description
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8565215 - Flags: review?(philip.chee)
Reporter

Updated

4 years ago
Blocks: 1133743
Assignee

Comment 2

4 years ago
Posted patch Updated patchSplinter Review
Fixes the fallout from bug 1133380 too.
Attachment #8565215 - Attachment is obsolete: true
Attachment #8565215 - Flags: review?(philip.chee)
Attachment #8567303 - Flags: review?(philip.chee)

Comment 3

4 years ago
Comment on attachment 8567303 [details] [diff] [review]
Updated patch

r=me

Some possible tweaks:
> +  background-image: url("chrome://global/skin/icons/warning-48.png");

> +  background-position: 30px 3em;
> -  -moz-padding-start: 30px;
> +  -moz-padding-start: 78px;
If you set -moz-padding-start to calc(3em + 48px + 3em)

> -#warningInnerBox
> +.title, .description
>  {
>    max-width: 50em;
Then you can remove the -moz-padding-start here:
> +  -moz-padding-start: 3em;

> -#warningTitle {
> +#privateTitle,
> +#normalTitle {
Then you can remove the -moz-padding-start here:
> +  -moz-padding-start: 0px;
> +  margin: 0 0 .6em;
> +  font-size: 160%;
Attachment #8567303 - Flags: review?(philip.chee) → review+
Assignee

Comment 4

4 years ago
Pushed comm-central changeset b0d45aade179.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.36
Assignee

Comment 5

4 years ago
Comment on attachment 8567303 [details] [diff] [review]
Updated patch

[Approval Request Comment]
Regression caused by (bug #): 1125636
User impact if declined: Ugliness
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Reporter

Comment 6

4 years ago
Comment on attachment 8567303 [details] [diff] [review]
Updated patch

Assuming that you meant to request branch approval for this patch, for some reason this didn't quite stick...
Attachment #8567303 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #8567303 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.