[RTL][Dialer] SIM(1) is displayed as {{n}}SIM in calling page.

RESOLVED DUPLICATE of bug 1130568

Status

defect
RESOLVED DUPLICATE of bug 1130568
5 years ago
5 years ago

People

(Reporter: huayu.li, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

Attachments

(3 attachments)

[1.Description]:
[RTL][Dialer] "(1)" or "(2)" beside SIM text can't be displayed normally in RTL.
See attachments:call in lockscreen.png, call in.png, call out.png
[2.Testing Steps]: 
Precondition:Change your device to Arabic language.
1.Launch dialer.
2.Call out a number.
3.Call in.
4.Call in in lockscreen.

[3.Expected Result]: 
2&3&4.(1) should be displayed at left side of "SIM",but in lockscreen, it should be displayed as SIM(1) as that in RTL mode.

[4.Actual Result]: 
2&3&4.The SIM(1)  is displayed as messy code.

[5.Reproduction build]: 

FLame2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,3/3

[7.TCID]: 
15424
Posted image call in.png
Posted image call out.png
QA Whiteboard: [dialer-rtl]
QA Whiteboard: [dialer-rtl] → [rtl-impact]
I think this is a dupe, ni on me to check this today
Flags: needinfo?(lebedel.delphine)
This is a duplicate of Bug 1130568 (where the exact same screenshot is attached). Closing
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → DUPLICATE
Duplicate of bug: 1130568
You need to log in before you can comment on or make changes to this bug.