Last Comment Bug 1133663 - Calendar display and calendar pane broken in Lightning 3.8b1, due to incomplete localizations
: Calendar display and calendar pane broken in Lightning 3.8b1, due to incomple...
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Lightning 3.8
: All Windows XP
-- normal (vote)
: 3.8
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
: 1136387 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-17 00:18 PST by patclash
Modified: 2015-03-14 04:22 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Tb34.0b1+Lightning3.6b1.png (118.62 KB, image/png)
2015-02-17 00:18 PST, patclash
no flags Details
Tb36.0b1+Lightning3.8b1.png (114.67 KB, image/png)
2015-02-17 00:19 PST, patclash
no flags Details

Description User image patclash 2015-02-17 00:18:22 PST
Created attachment 8565326 [details]
Tb34.0b1+Lightning3.6b1.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

Update TB 34.0b1 to 36.0b1;
Lightning 3.6b1 update to 3.8b1;


Actual results:

Calendar don't display in letf panel 
No color for event in the calendar panel 
(see screenshot Tb34.0b1+Lightning3.6b1.png)


Expected results:

Correct display like in Tb 34.0b1 with Lightning 3.6b1
(see screeshot Tb36.0b1+Lightning3.8b1.png)
Comment 1 User image patclash 2015-02-17 00:19:07 PST
Created attachment 8565328 [details]
Tb36.0b1+Lightning3.8b1.png
Comment 2 User image patclash 2015-02-17 00:28:41 PST
I have inverse the screeshot ....

Actual results:

Calendar don't display in letf panel 
No color for event in the calendar panel 
(see screeshot Tb36.0b1+Lightning3.8b1.png)

Expected results:

Correct display like in Tb 34.0b1 with Lightning 3.6b1
(see screenshot Tb34.0b1+Lightning3.6b1.png)
Comment 3 User image [:MakeMyDay] 2015-02-17 09:10:30 PST
Do you have any error messages in the log (ctrl+shift+j)?
Comment 4 User image patclash 2015-02-17 09:28:42 PST
(In reply to MakeMyDay from comment #3)
> Do you have any error messages in the log (ctrl+shift+j)?

Yes I have this error :

Erreur : TypeError: this.tree.view is undefined
Fichier Source : chrome://calendar/content/calendar-unifinder.js
Ligne : 624

When I click on the link :
the line " this.tree.view.selection.selectEventsSuppressed = true;" is highlight
Comment 5 User image [:MakeMyDay] 2015-02-17 13:46:39 PST
I don't see this on Daily anymore, but I remeber this error message - although it's potentially unrelated to the issue reported here. Can you please enable calendar.debug.log, calendar.debug.log.verbose and javascript.options.showInConsole in config editor and check the error console again?
Comment 6 User image Stefan Sitter 2015-02-17 13:58:33 PST
Your Thunderbird seems heavily modified. Do you use other extension that interact with Lightning and might not be compatible with Lightning 3.8b1 yet? Does the problem still exists if you disable all other extensions and switch back to Thunderbird default theme?
Comment 7 User image Richard Marti (:Paenglab) 2015-02-17 13:59:32 PST
I tried the french Lightning 3.8b1 and see the same. In the console I see this:

Zeitstempel: 17.02.2015 20:03:07
Fehler: Nicht definierte Entität
Quelldatei: chrome://calendar/content/calendar-calendars-list.xul
Zeile: 17, Spalte: 7
Quelltext:
      <menuitem id="list-calendars-context-togglevisible"

For example the entity calendar.context.togglevisible.accesskey is missing.

I tried the German Lightning and this works fine.
Comment 8 User image Stefan Sitter 2015-02-17 14:07:06 PST
sigh. once again problem with broken localizations in beta release?
Comment 9 User image Stefan Sitter 2015-02-17 14:28:18 PST
Based on quick search it seems that only 20 out of 35 localizations shipped with Lightning 3.8b1 contain the entity calendar.context.togglevisible.accesskey in calendar.dtd. Broken localizations would be en-GB, eu, fi, fr, hu, id, lt, nb-NO, nn-NO, pa-IN, pt-PT, ru, sv-SE, tr, and uk.
Comment 10 User image patclash 2015-02-17 14:35:32 PST
(In reply to MakeMyDay from comment #5)
> I don't see this on Daily anymore, but I remeber this error message -
> although it's potentially unrelated to the issue reported here. Can you
> please enable calendar.debug.log, calendar.debug.log.verbose and
> javascript.options.showInConsole in config editor and check the error
> console again?

I got that message : 
Horodatage : 17/02/2015 23:27:45
Erreur : entité non définie
Fichier Source : chrome://calendar/content/calendar-calendars-list.xul

(In reply to Stefan Sitter from comment #6)
> Your Thunderbird seems heavily modified. Do you use other extension that
> interact with Lightning and might not be compatible with Lightning 3.8b1
> yet? Does the problem still exists if you disable all other extensions and
> switch back to Thunderbird default theme?

Before I feel the bug report I have try to start with all extension disabled and only enable Lightning ;
the result is the same;
I use Thunderbird default theme (just Tab little modified with CSS style with Stylish)

Ligne : 17, Colonne : 7
Code Source :
      <menuitem id="list-calendars-context-togglevisible"

so same as  Richard Marti in comment #7
Comment 11 User image patclash 2015-02-17 23:42:38 PST
(In reply to Stefan Sitter from comment #9)
> Based on quick search it seems that only 20 out of 35 localizations shipped
> with Lightning 3.8b1 contain the entity
> calendar.context.togglevisible.accesskey in calendar.dtd. Broken
> localizations would be en-GB, eu, fi, fr, hu, id, lt, nb-NO, nn-NO, pa-IN,
> pt-PT, ru, sv-SE, tr, and uk.

I just install en-US version from https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/candidates/3.8b1-candidates/build2/win32/ :
display look fine;
so I can confirm that the localised version are broken ....
Comment 12 User image patclash 2015-02-21 08:09:10 PST
For a test , I just take the last Aurora 3.8a2 build from :
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2015/01/2015-01-12-00-40-01-comm-aurora-l10n/win32/
then modify the install.rdf file for TB 38.0b1 compatibility and install it :

That version work fine  :)
Comment 13 User image Stefan Sitter 2015-02-24 11:17:35 PST
Philipp, is it possible to release a Lightning 3.8b2 package without the broken localizations? Could you take care that the upcoming Lightning 3.9b1 contains only working localizations?
Comment 14 User image [:MakeMyDay] 2015-02-28 04:14:09 PST
*** Bug 1136387 has been marked as a duplicate of this bug. ***
Comment 15 User image Philipp Kewisch [:Fallen] 2015-02-28 04:17:06 PST
Yes, I can do this manually again. I hope to have a fix ready that would do a compare-locales run during the repacks, so we don't need to update the locales on each beta. Leaving ni? so I don't forget.
Comment 16 User image [:MakeMyDay] 2015-02-28 04:19:31 PST
Bug 1136890 indicates that there is more broken than the above mentioned string and further localizations are affected (for that bug, at least de).
Comment 17 User image [:MakeMyDay] 2015-03-01 04:39:14 PST
You can ignore my last comment. Bug 1136890 is not related to localization. Lightning 3.8 unfortunately didn't receive a backport of the patch for bug 1081534 to bring icaljs back to work.
Comment 18 User image [:MakeMyDay] 2015-03-02 09:38:31 PST
Although mention otherwise above, it turned out that there is an additional localization issue for the German locale with a different string in 3.8 documented in bug 1136890.
Comment 19 User image Robert Brand 2015-03-02 11:42:03 PST
(In reply to MakeMyDay from comment #18)
Yes, it seems for a Lightning 3.8b2 without broken localizations you'll have to sort out 'de' as well.
The problem is different from the one this bug is about and you don't see it immediately, but the localization is damaged because of 5 l10n-de-patches that took the wrong train (no options dialog, error in recurrence rules, ...). I backed them out once, but obviously that wasn't enough (or too late? I miss a sign-off history...).

I just created a fixed calendar-de.jar (and lightning.xpi) manually. If this can be of any use, I'll be glad to attach or mail it. If it can not, 3.8b2 has to go without 'de'.
Comment 20 User image Philipp Kewisch [:Fallen] 2015-03-02 13:42:25 PST
Feel free to send me the jar file, I'll incorporate it. I got started with using compare-locales with the -m argument, so in the future we might not have this problem anymore.
Comment 21 User image Stefan Sitter 2015-03-11 13:04:59 PDT
SeaMonkey 2.33 was released and now I see many reports about broken Lightning caused by this bug. Is there an ETA for Lightning 3.8b2?
Comment 22 User image Philipp Kewisch [:Fallen] 2015-03-11 15:33:40 PDT
Hm ok, so I ran compare-locales after updating to THUNDERBIRD_36_0b1_RELEASE using the changesets from https://l10n.mozilla.org/shipping/l10n-changesets?av=tb36

This is the result. I am a bit worried that en-GB shows up as working and you reported above its broken:

 
+ca
 cs
 da
-de
 en-GB
-en-US
+es-AR
 es-ES
 et
-fr
 fy-NL
+ga-IE
+gd
+hr
 is
 it
 ja linux win32
 ja-JP-mac osx
-ko
-lt
 nl
 pl
-pt-PT
 sk
-sl
+sq
 zh-CN
 zh-TW
Comment 23 User image Philipp Kewisch [:Fallen] 2015-03-12 05:43:06 PDT
Ok, I instead took locales from https://l10n.mozilla.org/shipping/l10n-changesets?ms=tb36_beta_b1 and the picture is more accurate now.

@@ -1,37 +1,19 @@
 ca
 cs
-cy
 da
-de
-en-GB
-en-US
 es-AR
 es-ES
 et
-eu
-fi
-fr
 fy-NL
 ga-IE
 gd
-hu
-id
+hr
 is
-it
 ja linux win32
 ja-JP-mac osx
-lt
-nb-NO
 nl
-nn-NO
-pa-IN
 pl
-pt-PT
-ru
 sk
 sq
-sv-SE
-tr
-uk
 zh-CN
 zh-TW


I took a moment to check each of the changesets in https://l10n.mozilla.org/shipping/l10n-changesets?av=tb36 for locales that are missing or have been added and will also add the working version following locales:

en-GB
hr
it

And of course the de locale that I received per email.
Comment 24 User image Philipp Kewisch [:Fallen] 2015-03-12 06:20:51 PDT
Please test these updated xpis. I've created them all with the same script, so if you've tested for one locale I can assume it works for all of them:

http://mozilla.kewis.ch/ltn38b2/lightning-linux.xpi
http://mozilla.kewis.ch/ltn38b2/lightning-win32.xpi
http://mozilla.kewis.ch/ltn38b2/lightning-mac.xpi
Comment 25 User image patclash 2015-03-12 07:46:38 PDT
I just test the win32 version ;
all seems to work, display look fine;
but it still in English on my French version of Thunderbird .....
I've see that there is no calendar-fr.jar and no lightning-fr.jar files in the *.xpi :(
Comment 26 User image Philipp Kewisch [:Fallen] 2015-03-12 08:00:16 PDT
Unfortunately the French locale contained missing strings, both in the officially signed off version and in the latest tb36 locale. Therefore I had to remove that locale. I'm sure it will be back for the next version.
Comment 27 User image Théo Chevalier [:tchevalier] 2015-03-12 08:48:20 PDT
(In reply to Philipp Kewisch [:Fallen] from comment #26)
> Unfortunately the French locale contained missing strings, both in the
> officially signed off version and in the latest tb36 locale. Therefore I had
> to remove that locale. I'm sure it will be back for the next version.

Not sure what happened, during last cycle, Calendar on Beta (36) was complete in French. There was missing strings on 37, but none on 36.

Currently, 37, 38, and 39 are complete.
Did I miss something about how sign-off are working for Calendar? If so, please let me know so that won't happen again.
Comment 28 User image Antony 2015-03-12 09:29:33 PDT
I just tried to load lightning-3.9b1.en-GB.mac.xpi with TB36 and not compatible...is this expected?
I am still using the en-US lightning as the en-UK still at 3.8b1 with same time stamp as the one that does not work
Comment 29 User image Antony 2015-03-12 09:31:35 PDT
I originally reported this on bug 1136387 as on a mac using Yosemite, 87 is marked as a dup of this bug... is that really true, are the two platform plugins the same in the main
Comment 30 User image Antony 2015-03-12 09:33:38 PDT
is this opening available yet:  Lightning 3.8b2 as not on the FTP site?
Comment 31 User image Antony 2015-03-12 10:39:27 PDT
for interest!!! I have loaded the TB 39b and the lightning 3.9b1 en-UK and Lightning works fine
Comment 32 User image Antony 2015-03-12 10:41:16 PDT
Sorry chaps... TB 37.0b1
Comment 33 User image Philipp Kewisch [:Fallen] 2015-03-12 11:47:32 PDT
Yes, Lightning 3.9b1 works with Thunderbird 37.0b1. This bug is mostly about Seamonkey 2.33 with Lightning 3.8b1. I'm glad the newer version works though!

Also, I've updated the builds at the above links to include a working French version.
Comment 34 User image patclash 2015-03-12 12:55:10 PDT
(In reply to Philipp Kewisch [:Fallen] from comment #33)

> Also, I've updated the builds at the above links to include a working French
> version.

I just tested this version and it work well :)

Just a question : why is Sunday the first day of the week when I update or install Lightning even if I've setup Monday as first day in the view tab before ? 
(In France the first day of the week is Monday)
Comment 35 User image Philipp Kewisch [:Fallen] 2015-03-12 15:27:28 PDT
(In reply to patclash from comment #34)

> 
> Just a question : why is Sunday the first day of the week when I update or
> install Lightning even if I've setup Monday as first day in the view tab
> before ? 
> (In France the first day of the week is Monday)

Not sure why this is happening. Could you file a separate bug, and also test if the same happens with the en-US version (and maybe also with the de version, where the week also starts on Monday)?

Marking this as fixed, I've uploaded the new beta to AMO.
Comment 36 User image Stefan Sitter 2015-03-13 10:32:27 PDT
At least the German localization shipped with 3.8b2 is still broken, see Bug 1142936.

Note You need to log in before you can comment on or make changes to this bug.