Closed Bug 1133967 Opened 5 years ago Closed 5 years ago

[Customizer] View CSS and JS files (no editing)

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cserran, Assigned: djf)

References

Details

(Whiteboard: [spark])

Attachments

(1 file)

41 bytes, text/x-github-pull-request
justindarc
: review+
Details | Review
No description provided.
No longer depends on: 1133947
Blocks: 1133968
No longer blocks: 1133968
No longer blocks: spark-p2p-sharing
Amy, Jacqueline, how do you intend to get to this view? I don't see a reasonable path to it with the current design. Maybe an additional option in the long-press menu to "View Source" if the target node is a `<link>` or has a `src` attribute?
Flags: needinfo?(jsavory)
Flags: needinfo?(amlee)
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #1)
> Amy, Jacqueline, how do you intend to get to this view? I don't see a
> reasonable path to it with the current design. Maybe an additional option in
> the long-press menu to "View Source" if the target node is a `<link>` or has
> a `src` attribute?

That's what I was thinking. In our current long-press action menu, we can add a "View Source" option for <link> and <script> tags.
(In reply to Justin D'Arcangelo [:justindarc] from comment #2)
> That's what I was thinking. In our current long-press action menu, we can
> add a "View Source" option for <link> and <script> tags.

Seems reasonable to me. Though, IMO, our qualifiers for this additional button should be `<link>` and `<script>` elements or the `src` attribute, so that we could also view images (the code path should be nearly identical).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Taking this to see if I can move it forward at all.
Assignee: nobody → dflanagan
Status: NEW → ASSIGNED
Justin,

Here's the PR for view source. Since I'm new to this framework, I don't think I should land it myself without your review.

I don't have write access to the customizer repo so you'll have to land it anyway.
Attachment #8566886 - Flags: review?(jdarcangelo)
Comment on attachment 8566886 [details] [review]
link to patch on github

LGTM. Landed. Also, I'll add you to the repo owners group so you can land in the future. Thanks!
Attachment #8566886 - Flags: review?(jdarcangelo) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
The design for this has been added in the spec, one of the toolbar icons will represent 'View Source'. Let me know if this works.
Flags: needinfo?(jsavory)
Whiteboard: [lightsaber] → [spark]
Flags: needinfo?(amlee)
You need to log in before you can comment on or make changes to this bug.