Closed Bug 1134076 Opened 5 years ago Closed 5 years ago

HTML5 enforced but quality options are limited.

Categories

(Firefox :: Untriaged, defect)

35 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 778617

People

(Reporter: gumballisthegreatest, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

I have tried clearing cookies.


Actual results:

HTML5 was still enforced with limited quality options.


Expected results:

I would have reverted back to Flash with unlimited quality options.
And I am talking about Media Source Extensions, MSE H.264 and MSE & WebM VP9 not being supported.
(In reply to gumballisthegreatest from comment #1)
> And I am talking about Media Source Extensions, MSE H.264 and MSE & WebM VP9
> not being supported.

So what is the specific problem this creates?
(In reply to Andre Klapper from comment #2)
> (In reply to gumballisthegreatest from comment #1)
> > And I am talking about Media Source Extensions, MSE H.264 and MSE & WebM VP9
> > not being supported.
> 
> So what is the specific problem this creates?

Hello, this limits quality settings. Only 360p and 720p are available.
Apparently MSE (note that all three unavailable things are MSE) is not implemented well enough yet even on Windows where they tried to enable it by default: bug 1129039.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: MSE
(In reply to gumballisthegreatest from comment #3)
If you want to try helping, you could try out the Nightly build of Firefox. 
Other than resolutions over 1080p, my HTML5 playback is flawless now.
Besides following bug778617
The discussions and workarounds may be of interest
> YouTube Forces Firefox to use HTML5 instead of FlashPlayer
> https://support.mozilla.org/en-US/forums/contributors/711053
You need to log in before you can comment on or make changes to this bug.