[RTL][Window Mgmt] Privacy controls has undesired transition when opening via settings

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: DerekH, Assigned: gandalf)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(4 attachments)

Created attachment 8566288 [details]
Privacy Controls Transition Logcat

Description:
When the user accesses the Privacy controls through the settings app, the page will be displayed in LTR layout. Then it will transition into an RTL layout after a short delay. This happens every time the user accesses this page.

Prerequisite: Set language to Arabic (عربي)

Repro Steps:
1) Update a Flame to 20150217074222
2) Open Settings App
3) Select Privacy Controls
4) Observe Transition


Actual:
The screen transitions into the RTL layout every time this page is opened.


Expected:
The page should be loaded into the RTL layout before the user sees the transition

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150217074222
Gaia: ae02fbdeae77b2002cebe33c61aedeee4b9439fd
Gecko: 4bb425001d8a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/c7Cxuhc5huw
This issue DOES reproduce on Flame 2.2

The screen transitions into the RTL layout every time this page is opened.

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150218002515
Gaia: da509caa7395d3d090ce973e8de082b4680a590d
Gecko: 96da179a7d3a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Adding qawanted to check if the transition delay is a general issue (happens on LTR as well) and not RTL specific. Please nominate to 3.0? if that's the case based on your findings.
Keywords: qawanted
(In reply to bhavana bajaj [:bajaj] from comment #2)
> Adding qawanted to check if the transition delay is a general issue (happens
> on LTR as well) and not RTL specific. Please nominate to 3.0? if that's the
> case based on your findings.

The transition delay does not happen on LTR. It is specific to RTL. Tested on Afrikaans and English for LTR reference.

Device: Flame 3.0 (full flash 319MB)
BuildID: 20150223103044
Gaia: 288bf1c58ef9ccecd68508978a0141ee71974681
Gecko: 9b077c6f3d02
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
I don't think this is specific to RTL, it looks more like a localization issue with any language. Every time I enter the privacy controls section, the screen is initially presented in en-US and then it switches to the proper language. 

It is more jarring with RTL because the orientation of the text and carats all flip around, but I see the same basic problem with French and Italian.
No longer blocks: 1071891
blocking-b2g: --- → 2.2?
NI privacy control QA owner.
Flags: needinfo?(gchang)
Hi Marta,
This might need your help.
Blocks: 1057675
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][COM=Privacy Panel]
Flags: needinfo?(gchang) → needinfo?(marta)

Comment 7

3 years ago
I guess this is because PC is a separate app, and not really part of the settings. Not sure what can be done to fix that
Flags: needinfo?(marta)

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
ni on Gandalf so he can see if this is an l10n issue as per comment 4
Flags: needinfo?(gandalf)
(Assignee)

Comment 9

3 years ago
How can I get the privacy controls entry in my Settings? I don't see it when I flash master.
Zibi, it's now only available in engineering builds.
Created attachment 8578409 [details] [review]
[gaia] zbraniecki:1134448-privacy-controls-fouc > mozilla-b2g:master
(Assignee)

Comment 12

3 years ago
Comment on attachment 8578409 [details] [review]
[gaia] zbraniecki:1134448-privacy-controls-fouc > mozilla-b2g:master

Ok, so someone overengineered lazyloading of l10n.js. It was loading after alameda as a module, while UI with text was inlined, so firstPaint happened way before any localization.

I moved it to defer, because it seems to work without FOUC.
Flags: needinfo?(gandalf)
Attachment #8578409 - Flags: review?(kgrandon)
Comment on attachment 8578409 [details] [review]
[gaia] zbraniecki:1134448-privacy-controls-fouc > mozilla-b2g:master

Nice find Zibi! I think this looks fine to me, but I also think Marta should probably take a look. If we're in a rush to land this though, we could always land first and get a retroactive review from Marta. Thanks!
Attachment #8578409 - Flags: review?(marta)
Attachment #8578409 - Flags: review?(kgrandon)
Attachment #8578409 - Flags: review+

Updated

3 years ago
Attachment #8578409 - Flags: review?(marta) → review+

Updated

3 years ago
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 on this when you get a chance.
status-b2g-master: affected → fixed
Flags: needinfo?(gandalf)
Target Milestone: --- → 2.2 S8 (20mar)
(Assignee)

Comment 16

3 years ago
Comment on attachment 8578409 [details] [review]
[gaia] zbraniecki:1134448-privacy-controls-fouc > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): privacy controls
[User impact] if declined: FOUC at start when using non-default locale
[Testing completed]: on flame
[Risk to taking this patch] (and alternatives if risky): not known
[String changes made]: none
Flags: needinfo?(gandalf)
Attachment #8578409 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8578409 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 17

3 years ago
Created attachment 8579745 [details]
video.MP4

This issue has been verified successfully on Flame 3.0, the page loaded into the RTL layout before the user sees the transition.
See attachment:video.MP4
Rate:0/5

Flame 3.0 build: pass
Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.093634
Firmware Date          Wed Mar 18 09:36:44 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][COM=Privacy Panel] → [QAnalyst-Triage+][rtl-impact][COM=Privacy Panel][MGSEI-Triage+]
status-b2g-master: fixed → verified
Keywords: verifyme

Comment 19

3 years ago
Created attachment 8581371 [details]
verify_v2.2.MP4

This issue has been verified successfully on Flame 2.2, the page loaded into the RTL layout before the user sees the transition.
See attachment:verify_v2.2.MP4
Rate:0/5

Flame 2.2 build: pass
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.