Closed Bug 1134497 Opened 6 years ago Closed 6 years ago

Implement infopanels for in-product FTU Reading List/View tour

Categories

(Firefox :: Tours, defect, P1)

defect
Points:
8

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Dolske, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reader-ui])

See UX mocks in bug 1132951 (currently "Reading List, First Time Use Experience" in the middle-right of attachment 8566332 [details]).

These are info panels to point out articles in the sidebar, the reading mode button, and sync. (The mock currently highlights Sync in the menu panel, but this may change to be a sync-promo blurb at the bottom of the sidebar).

We also probably want to combine the first infopanel with the "#3 Transition state" panel since they're so similar?
Additional note: if the use navigates away from the reading mode page loaded to start this tour, we should close the infopanels and consider the tour concluded. These infopanels will need to be triggered in-product, as the tour page itself can not (because it will be in Reader View, which isn't running JS).
Required for Campaign Release
Blocks: 1132074
Flags: qe-verify?
Flags: firefox-backlog+
Points: --- → 8
Priority: -- → P1
The most up to date wireframe for the tour will be found in the nonobsolete attachment in bug 1129536.
Flags: qe-verify? → qe-verify+
QA Contact: andrei.vaida
See Also: → 1147484
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 40.1 - 13 Apr
:jaws - can you please confirm that the comment in bug 1147484 comment 3 is accurate? If so, I will close that bug as a duplicate of this.
Flags: needinfo?(jaws)
I commented and closed bug 1147484 as that was fixed by bug 1133485.
Flags: needinfo?(jaws)
Whiteboard: [reader-ui]
Iteration: 40.1 - 13 Apr → 40.2 - 27 Apr
Assignee: jaws → nobody
Status: ASSIGNED → NEW
Iteration: 40.2 - 27 Apr → ---
Closing this since we're not (currently) planning on shipping Reading List.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.