Closed Bug 1147484 Opened 5 years ago Closed 5 years ago

Open the Reading List panel when the user is on the FTU

Categories

(Firefox :: Tours, defect, P1)

36 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ckprice, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reader-ui])

It is important that the Reading List panel open during FTE. We're reliant on the pre-populated articles and open Reading List panel to teach users about all tools that we offer that support reading behavior. 

This is based on the approved Reading List FTU wireframe (attachment 8574210 [details]). 

Adding as a P1 as it directly affects development, and would change currently opened infopanel bugs.
:clarkbw - per our email thread, if there is already a bug that addresses this somewhere, please let us know.
Flags: needinfo?(clarkbw)
Looks like the other bug is different, getting this on the backlog.
Flags: needinfo?(clarkbw) → firefox-backlog+
I think this was already going to happen in bug 1134497 when the panels got implemented but perhaps not.
See Also: → 1134497
I'm not sure what is meant by "FTU - first time use". We do open the Reading List the first time an article is added to Reading List, if that's what you're asking. This was fixed by bug 1133485.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1133485
Pasting comment 0 here

(In reply to Cory Price [:ckprice] from comment #0)
> It is important that the Reading List panel open during FTE. We're reliant
> on the pre-populated articles and open Reading List panel to teach users
> about all tools that we offer that support reading behavior. 
> 
> This is based on the approved Reading List FTU wireframe (attachment 8574210 [details]
> [details]). 
> 
> Adding as a P1 as it directly affects development, and would change
> currently opened infopanel bugs.

See also bug 1134501.

The flow/doorhangers depend on the Reading List panel to be open when the user lands on the Reading List FTU page.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
See Also: → 1134501
In that case, it was fixed by bug 1134446.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134446
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #6)
> In that case, it was fixed by bug 1134446.

Are you sure that's handling the case where the user lands on our hosted FTU page and needs to open the reading list even if it's not actually their first time. That's what I thought this bug was handling.
Flags: needinfo?(jaws)
I guess I didn't understand what was meant by FTU/FTE. Bug 1134446 won't trigger opening the Reading List if it's already been opened before.
Status: RESOLVED → REOPENED
Flags: needinfo?(jaws)
Resolution: DUPLICATE → ---
Blocks: 1132074
Whiteboard: [reader-ui]
Closing this since we're not (currently) planning on shipping Reading List.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.