[RTL][Rocket Bar] Settings icon is not on the right side of "No internet connection"

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: apastor)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(8 attachments)

(Reporter)

Description

4 years ago
Posted image SettingsICon.png
Description:
When the user tries to search on the rocket bar without the internet connection, the settings icon with the string "No internet connection" is not right-aligned.
   
Pre-requisite: Wi-fi and cellular data are not connected.

Repro Steps:
1) Update a Flame device to BuildID: 20150204010225.
2) Set the device language in Arabic under Settings > Language.
3) Select the rocket bar on the homescreen.
4) Type any letter.
5) Observe the settings icon's location with the string "No internet connection".

Actual:
The settings icon is on the left side of the string.
  
Expected: 
The settings icon is on the right side of the string.

Device: Flame Master (319mb, full flash)
Build ID: 20150204010225
Gaia: dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko: 0c2f7434c325
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2 (319mb, full flash)
BuildID: 20150204002509
Gaia: a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gecko: 8669c26fd4a5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15684/
Flags: in-moztrap+
RTL triage: P2 for now, but fairly minor. It's very hard to tell that the icon is a button anyway, not clear if this has much impact.
feature-b2g: --- → 2.2+
Priority: -- → P2
feature-b2g: 2.2+ → ---
Priority: P2 → P3
Assignee: nobody → nefzaoui
Attachment #8565370 - Flags: review?(kgrandon)
Comment on attachment 8565370 [details] [review]
[gaia] anefzaoui:bug-1129701 > mozilla-b2g:master

This seems to work well for me, and I can't find any regressions. Great work as usual Ahmed!
Attachment #8565370 - Flags: review?(kgrandon) → review+
http://docs.taskcluster.net/tools/task-graph-inspector/#22HCdNbwTt-SAnGhydGGKw

The pull request failed to pass integration tests. It could not be landed, please try again.
Depends on: 1133971
Ahmed - now that bug 1133971 has landed can you rebase this against master and see what gaia-try says? Thanks!
Flags: needinfo?(nefzaoui)
Pushed.
Let's just wait and see..
Flags: needinfo?(nefzaoui)
Everything looks green now, so let's give it a shot.
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8565370 [details] [review]
[gaia] anefzaoui:bug-1129701 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Lack of RTL support
[User impact] if declined: attachment 8559470 [details]
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): very low risk to none, css RTL changes
[String changes made]: none
Attachment #8565370 - Flags: approval-gaia-v2.2?
Attachment #8565370 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is fixed in the latest Nightly 3.0 and 2.2 Flame builds.  

Results:  The settings icon is on the right of the text in RTL languages.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Depends on: 1134918
Depends on: 1134742
Target Milestone: 2.2 S6 (20feb) → ---
Attachment #8565370 - Flags: approval-gaia-v2.2+
Ahmed - is this something that you'll be able to revisit?
Flags: needinfo?(nefzaoui)
Whiteboard: [systemsfe]
Blocks: 1141467
Blocks: 1139807
Nominating to block as this blocks other RTL bugs, which are now blockers.
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
I guess we have to find someone else here.
Assignee: nefzaoui → nobody
Alberto, can you fix the regressions and reland this patch?
Flags: needinfo?(nefzaoui) → needinfo?(apastor)
(Assignee)

Comment 18

4 years ago
Sure
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Duplicate of this bug: 1139807
(Assignee)

Updated

4 years ago
Attachment #8577189 - Flags: review?(mhenretty)
Comment on attachment 8577189 [details] [review]
[gaia] albertopq:1129701-icon-search > mozilla-b2g:master

Overall the code looks good. Right now we have a small problem with the search provider drop-down icon always displaying on the left (even in RTL mode). I also left question on github. Feel free to reflag me when the drop-down icon is fixed.
Attachment #8577189 - Flags: review?(mhenretty)
(Assignee)

Comment 22

4 years ago
Posted image RTL
(Assignee)

Comment 23

4 years ago
Posted image LTR
(Assignee)

Comment 24

4 years ago
I just attached 2 screenshots, showing how I see the search screen in both LTR and RTL with the patch. I can see the dropdown icon at the right on RTL, and on the left on LTR. I probably misunderstood something. Could you please clarify? Thanks!
Flags: needinfo?(mhenretty)
Oh, that's weird. I was seeing it always display on the left. In any case, the drop down icon (the little triangle before Yahoo search) should be on the right of the text for English, and left for Arabic. That is how it is on the current master. It looks like your patch reverses those.
Flags: needinfo?(mhenretty)
(Assignee)

Updated

4 years ago
Attachment #8577189 - Flags: review?(mhenretty)
Comment on attachment 8577189 [details] [review]
[gaia] albertopq:1129701-icon-search > mozilla-b2g:master

LGTM! Nice work.
Attachment #8577189 - Flags: review?(mhenretty) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 28

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/8c9cb3713ce4e222ff90d96bd05e0659c8ce5016
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Please uplift to v2.2. Thanks.
Keywords: verifyme
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1141467

Comment 31

4 years ago
Posted image settings_icon.png
This issue has been verified fail on latest build of Flame 3.0, the settings icon still displayed at left side of text.
See attachment:settings_icon.png
Rate:5/5

Flame 3.0 build: fail
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
According to comment 31, reopen this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 33

4 years ago
Given that gaia revision (c39e15f631de80c69467fda0d4ea0bcda9e194ca), the commit for this bug wasn't included into that build yet [1].

Could you please, re-verify with today's mozilla-central, or flash latest master gaia on the current one to verify? Thanks!


[1] https://github.com/mozilla-b2g/gaia/blob/c39e15f631de80c69467fda0d4ea0bcda9e194ca/apps/search/style/search.css#L23
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(lulu.tian)
Resolution: --- → FIXED

Comment 34

4 years ago
This issue has been verified seccussfully on latest build of Flame 3.0, the settings icon is displayed at right side of text.
See attachment:2015-03-22-20-09-46.png
Rate:0/5

Flame 3.0 build: pass
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lulu.tian)

Updated

4 years ago
NI myself for following v2.2 verification.
Flags: needinfo?(hcheng)
Alberto, could you uplift to 2.2? Thanks.
Flags: needinfo?(hcheng) → needinfo?(apastor)
(Assignee)

Comment 37

4 years ago
Comment on attachment 8577189 [details] [review]
[gaia] albertopq:1129701-icon-search > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Settings icon is on the wrong position on RTL
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Low risk. Only css and html
[String changes made]: none
Flags: needinfo?(apastor)
Attachment #8577189 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8577189 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Sue, could you verify 2.2 once pvt build includes this patch?
Flags: needinfo?(lulu.tian)

Comment 40

4 years ago
This patch had been uplifted to latest build of Flame 2.2, and this issue has been verified successfully on latest build of Flame 2.2, the settings icon is displayed at right side of text.
See attachment:correct_settings_icon.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lulu.tian)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.