Icon doesn't show for Twitter app

RESOLVED DUPLICATE of bug 1134005

Status

defect
RESOLVED DUPLICATE of bug 1134005
4 years ago
2 months ago

People

(Reporter: benfrancis, Unassigned)

Tracking

({dogfood})

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:
* Install Twitter app
* View homescreen

Expected:
* The Twitter app has a Twitter icon

Actual:
* The Twitter app has the default icon

Reproduced 2/2 times
(Reporter)

Comment 1

4 years ago
Posted image screenshot
Screenshot attached.

Probably not a homescreen bug, but filing here to start debugging.
(Reporter)

Comment 2

4 years ago
Encountered on 2.2 nightly build
(Reporter)

Comment 3

4 years ago
Can QA reproduce this? If so, please nominate for 2.2+
Keywords: qawanted
QA Contact: ychung
I reproduced this bug on Flame Master, 2.2, 2.1, and Base Image V18D-1(2.0) and V188-1 (2.0).

Result: The default icon is displayed when Twitter app is downloaded from Marketplace.

Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (KK, 319mb, shallow flash)
BuildID: 20150219075643
Gaia: 373df4bec2c20228f45be0b24111252171f925e9
Gecko: 10c100cba54d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ychung
(Reporter)

Comment 5

4 years ago
Thank you, nominating for 2.2+. If this is reproducing as far back as 2.0 I'd say there's a good chance the problem is on Twitter's side, maybe they broke their manifest or their icon URLs are 404ing.
blocking-b2g: --- → 2.2?
Keywords: dogfood
Whiteboard: [systemsfe]
blocking-b2g: 2.2? → 2.2+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I'll take a look. I can reproduce this, though the Twitter app's icon used to work fine.

Maybe just the URL in the manifest is broken? Will check.
Status: NEW → ASSIGNED
QA Contact: chrislord.net
I think these assignee fields got swapped.
Assignee: nobody → chrislord.net
QA Contact: chrislord.net
So just looked into this, the problem is that the icons specified for the manifest no longer exist.

You can find the manifest here:
https://mobile.twitter.com/cache/twitter.webapp

The icons are /images/larrybird-30.png (and -60 and -128), none of which exist on that domain anymore.

This is, I guess, an evangelism problem?

This probably shouldn't be blocking, but I'll let us pick it up in the next stand-up.
Assignee: chrislord.net → nobody
Status: ASSIGNED → NEW
Component: Gaia::Homescreen → Mobile
Product: Firefox OS → Tech Evangelism
Karl, do we have Twitter contacts?
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #10)
> dup of bug 1134005?

Yes, looks like it - if we dupe this one, we should make sure to copy the blocking flag and comment #8.
Whiteboard: [systemsfe]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134005
(Assignee)

Updated

2 months ago
Component: Mobile → Mobile
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.