[Dialer][USSD] Abbreviated Dialing Codes can be activated by backspacing/deleting numbers in the dialer field.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: gsvelto)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8566807 [details]
logcat-ADC-Backspace.txt

Description:
If the user has a '#' symbol in their dialer field, Abbreviated Dialing Codes can be activated if the user backspaces or deletes back to the '#' symbol.

The activation of the ADC code from tapping backspace can be confusing to the user.

Repro Steps:
1) Update a Flame to 20150219010228
2) Ensure there is a SIM card in the phone.
3) Open the Dialer app
4) Enter '123' into the dialer field
5) Move the input cursor between the '1' and '2' and input a '#' symbol so the dialer field now displays '1#23'
6) Return the cursor to the end of the line, and hit backspace twice to delete the '3' and the '2'

Actual:
The Abbreviated Dialing Code '1#' is activated after hitting backspace.

Expected:
The Abbreviated Dialing Code is not activated by hitting the backspace.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: logcat, video (URL)
(Reporter)

Comment 1

3 years ago
This issue DOES occur in Flame 2.2.
The Abbreviated Dialing Code '1#' is activated after hitting backspace.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------------------------

This issue does NOT occur in Flame 2.1 builds.
Abbreviated Dialing Codes are not implemented in this branch.

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
Build ID: 20150210002200
Gaia: 7dd130a312f12c89b2d41948f8557effa56afbf6
Gecko: 2de03dfa9aac
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]: New feature which can be triggered while a user is consciously executing another action (delete).
Blocks: 1061130
blocking-b2g: --- → 2.2?
Created attachment 8567068 [details] [review]
[gaia] gabrielesvelto:bug-1134871-speed-dial-delete > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Comment on attachment 8567068 [details] [review]
[gaia] gabrielesvelto:bug-1134871-speed-dial-delete > mozilla-b2g:master

Somehow I forgot about this requirement while I already had code in place to handle this when typing the IMEI MMI code. Tamara, if you haven't reviewed the patch for bug 1131261 yet I think it's better if you start by reviewing this one and then I'll rebase that one on top. This is a more urgent issue as it's plainly incorrect behavior.
Attachment #8567068 - Flags: review?(thills)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Hi Gabriele,

It looks good to me.  I had a nit in the PR and also a question about something that wasn't clear to me.  If you can clarify, that will be great.  I did test it out as well.

Thanks,

-tamara
Flags: needinfo?(gsvelto)
(Assignee)

Comment 6

3 years ago
(In reply to Tamara Hills [:thills] from comment #5)
> It looks good to me.  I had a nit in the PR and also a question about
> something that wasn't clear to me.  If you can clarify, that will be great. 
> I did test it out as well.

I've replied inline to your comments and pushed another patch on top of the existing one addressing them.
Flags: needinfo?(gsvelto)
Comment on attachment 8567068 [details] [review]
[gaia] gabrielesvelto:bug-1134871-speed-dial-delete > mozilla-b2g:master

Gabriele,

Thanks for the explanation and the addditional comment you added.

-tamara
Attachment #8567068 - Flags: review?(thills) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Triage: Confusing behavior on a new feature.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 10

3 years ago
Comment on attachment 8567068 [details] [review]
[gaia] gabrielesvelto:bug-1134871-speed-dial-delete > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1061130
[User impact] if declined: Confusing behavior when editing number with a # in the dialer
[Testing completed]: Tested on a device, added unit-tests to cover this scenario
[Risk to taking this patch] (and alternatives if risky): Backing out bug 1061130
[String changes made]: None
Attachment #8567068 - Flags: approval-gaia-v2.2?(release-mgmt)
Reassigning to Bhavana (release-mgmt@mozilla.com is now about Firefox Desktop/Mobile)
Flags: needinfo?(bbajaj)

Updated

3 years ago
Flags: needinfo?(bbajaj)
Attachment #8567068 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/1955af0bd6bf97213e6722c549fffbf203b91be4
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
This issue is verified fixed on the latest Nightly 3.0 and 2.2 builds.
	
Actual results:  Abbreviated dialer codes do not trigger by deleting towards a # symbol.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.