Closed Bug 1149083 Opened 5 years ago Closed 5 years ago

[Dialer]Device will playing the DTMF tone after we tap a number and then tap "#" key during a call.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: huayu.li, Assigned: gsvelto)

References

Details

(Keywords: regression, Whiteboard: [v2.2-nexus-5-l])

Attachments

(3 files)

Attached file logca1.txt
[1.Description]:
[Nexus 5 v2.2&v3.0][Flame v2.2][Dialer]During a call, user enable the speaker, open the keyboard and tap a number, then tap "#" key, the device will keep ringing in high volume, it's confounded.
Found at:14:48 around
see attachments:logcat1.txt, video 1.3gp.

[2.Testing Steps]: 
1.Launch dialer.
2.Call out a number.
3.Enable speaker.
4.Open keyboard.
5.Tap a number and then tap # key, ex : 1#

[3.Expected Result]: 
5.The ring should not continue.

[4.Actual Result]: 
5.You can hear the device keeps ringing in a high volume.

[5.Reproduction build]: 
N5 v2.2 build(Affected):
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-

b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150329.035946
Firmware Date          Sun Mar 29 03:59:59 EDT 2015
Bootloader             HHZ12d

Nexus 5_3.0 version(Affected):

Build ID               20150329160203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150329.193532
Firmware Date          Sun Mar 29 19:35:48 EDT 2015
Bootloader             HHZ12d

Flame 2.2 version(Affected):
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.035453
Firmware Date          Sun Mar 29 03:55:05 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
occasionally Recurrence,10/15

[7.TCID]: 
Free Test

[8.Note]:
The bug still exist in Flame 2.2.
Attached video 1.3gp
I don't reproduce on 2.1[1] but I do on 2.2[2].

[Blocking Requested - why for this release]: Major regression on the dialer.


[1] Build ID               20150327001204
Gaia Revision          6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gaia Date              2015-03-25 11:16:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f4d7c0e7292e
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880

[2] Build ID               20150329162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.200030
Firmware Date          Sun Mar 29 20:00:41 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.2?
Summary: [Dialer]Device will keep ringing after we tap a number and then tap "#" key during a call. → [Dialer]Device will playing the DTMF tone after we tap a number and then tap "#" key during a call.
Possibly a regression from bug 1061130
I will find the regressionwindow.
ni to investigate this. We might not have to if the regression window gives us a good enough picture of what broke.
Flags: needinfo?(gsvelto)
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150223052827
Gaia: c79b08251a6d43953f067d9acc185504d4d27142
Gecko: 2a9d07ad0cae
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150223072341
Gaia: 0cbf347634255353850d06221fa29e9be0bb4364
Gecko: 8f7d46908658
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: c79b08251a6d43953f067d9acc185504d4d27142
Gecko: 8f7d46908658

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 0cbf347634255353850d06221fa29e9be0bb4364
Gecko: 2a9d07ad0cae

https://github.com/mozilla-b2g/gaia/compare/c79b08251a6d43953f067d9acc185504d4d27142...0cbf347634255353850d06221fa29e9be0bb4364

caused by bug 1134871
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Gabriele, can you take a look at this please? This looks to have been caused by the landing and uplift for bug 1134871
Blocks: 1134871
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Yes, I know what's wrong with this and I'll fix it ASAP.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8586080 [details] [review]
[gaia] gabrielesvelto:bug-1149083-no-speed-dial-during-call > mozilla-b2g:master

This is a one-line fix plus unit-tests. It should be pretty safe to uplift; Tamara if this passes review do you mind landing and uplifting this on my behalf please?
Attachment #8586080 - Flags: review?(thills)
Comment on attachment 8586080 [details] [review]
[gaia] gabrielesvelto:bug-1149083-no-speed-dial-during-call > mozilla-b2g:master

Hi Gabriele,

Looks good.  I tested out and it fixes the issue.

Thanks,

-tamara
Attachment #8586080 - Flags: review?(thills) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
ni for uplift to v2.2.
Flags: needinfo?(thills)
Comment on attachment 8586080 [details] [review]
[gaia] gabrielesvelto:bug-1149083-no-speed-dial-during-call > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1061130
[User impact] if declined: If user is on a call and enters DTMF like '1#' or something terminating with a # key, they will hear a non-ending DTMF tone on the call.
[Testing completed]: yes.
[Risk to taking this patch] (and alternatives if risky):  Low as it's a 1-line change.
[String changes made]: none.
Flags: needinfo?(thills)
Attachment #8586080 - Flags: approval-gaia-v2.2?(bbajaj)
Keywords: verifyme
Attachment #8586080 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue has been verified successfully on Nexus5 3.0:
Reproducing rate: 0/5
Nexus5 3.0[Verified]
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150402.192539
Firmware Date          Thu Apr  2 19:25:53 EDT 2015
Bootloader             HHZ12d
This issue had been successfully verified on Flame 2.2 and nexus5 2.2
Reproducing rate: 0/5
Flame 2.2 [Verified]:
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 [Verified]:
Serial: 071f208800d21443 (State: device)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150406.035757
Firmware Date          Mon Apr  6 03:58:14 EDT 2015
Bootloader             HHZ12d
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.