Closed Bug 1135062 Opened 5 years ago Closed 5 years ago

[Youtube] Clicking Next/Previous in full screen after seek, causes the HTML5 player to crash

Categories

(Core :: DOM: Core & HTML, defect, P1, major)

37 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox36 --- unaffected
firefox37 + fixed
firefox38 + fixed

People

(Reporter: FlorinMezei, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Reproducible with: 
- latest Firefox 37 Aurora - BuildID: 20150220004124 - HTML5 player crashes when clicking next (will file separately)
- latest Firefox 38 Nightly - BuildID: 20150220030202 - HTML5 player crashes when clicking next (will file separately)

NOT reproducible on:
- Firefox 36 RC - BuildID: 20150219174507 - bug 1135052 was filed for Firefox 36

Reproducible on: Mac OS X 10.9.5 (Retina), Windows 7 x64, Windows 8.1 x86

NOT yet verified: Ubuntu 14.04 x64

Steps to reproduce:
1. Open Firefox and go to https://www.youtube.com/html5 and click "Request the HTML5 player".
2. Open a list o videos e.g. https://www.youtube.com/watch?v=y6Sxv-sUYtM&list=RDy6Sxv-sUYtM#t=1.
3. Enter fullscreen.
4. Seek forward and wait for ~5-6 seconds to pass then click the Next button (repeat step a few times if not reproducible on first try).

Expected results:
Next video starts to play automatically.

Actual results:
Video exits HTML5 full screen and video restarts with Flash player.

Notes:
- I'll try to get a regression window for this today, but so far it looks like the issue appeared somewhere between October 10th and October 25th
[Tracking Requested - why for this release]:
HTML5 (MSE?) YouTube usability issue.
This sounds like a dom or youtube issue with our fullscreen implementation, rather than a video playback problem. N.B. it's probably not reproducible on Ubuntu (or 36) because we don't support MSE there and YouTube is serving a different page.
Component: Video/Audio → DOM
I have a regression window on Windows 7 x64, and it seems this appeared when we enabled MSE:

Nightly 2014-10-23 -> GOOD
Mime Type: video/mp4; codecs="avc1.42001E, mp4a.40.2"
DASH: no (18)

Nightly 2014-10-24 -> BAD
Mime Type: video/webm; codecs="vp9"
DASH: yes (243/171)

Nightly 2015-02-20 -> BAD
Mime Type: video/mp4; codecs="avc1.4d401e"
DASH: yes (134/140)

Last good revision: 88adcf8fef83 (2014-10-23)
First bad revision: d6abb9bf43be (2014-10-24)
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=88adcf8fef83&tochange=d6abb9bf43be
Keywords: regression
Andrew - In comment 2 Ralph suggests that this may be DOM related. As this impacts fullscreen video on YouTube, can you please find someone to investigate for the 37 time frame?
Flags: needinfo?(overholt)
If this was triggered by MSE (or, coincidentally, by fullscreen ;), it should probably go to Chris.
Flags: needinfo?(overholt) → needinfo?(cpearce)
Someone on the MSE team should look into this...
Flags: needinfo?(cpearce) → needinfo?(ajones)
Blocks: MSE
Flags: needinfo?(ajones)
Bobby - can you look into this?
Flags: needinfo?(bobbyholley)
Priority: -- → P1
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #7)
> Bobby - can you look into this?

Realistically, I doubt I'll have time to look at this within the next week.
Flags: needinfo?(bobbyholley)
Does it still occur on 37 beta?
Flags: needinfo?(florin.mezei)
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #9)
> Does it still occur on 37 beta?

I've tried this over the past couple of days on Windows 7 x64, and Mac OS X 10.9.5, but I was no longer able to reproduce the issue with:
- Firefox 37 Beta 2 & 3
- latest Firefox 38 Aurora
- latest Firefox 39 Nightly

What's weirder is that I can no longer reproduce this issue on older Nightly builds after October 24th. When I filed the bug, issue was easily reproducible on those builds. Is it possible that something changed on YouTube's side that no longer affects us? 

I tested without being signed in (every video in fullscreen was automatically started in HD) and when signed in, with the setting for automatically loading HD in fullscreen disabled.
Flags: needinfo?(florin.mezei)
One more note here: I noticed that now, each time you go to the next video in fullscreen, if you then choose to exit fullscreen, that video will restart. This also happens on Chrome, but I don't remember seeing it in previous days.

Here's the exact scenario for this new issue:
1. Open Firefox and go to YouTube (make sure HTML5 is used to play videos - otherwise go to https://www.youtube.com/html5 and click "Request the HTML5 player").
2. Open a list of videos e.g. https://www.youtube.com/watch?v=y6Sxv-sUYtM&list=RDy6Sxv-sUYtM#t=1.
3. Enter fullscreen.
4. Click Next to load the next video (or you can also seek close to the end so the next video will start).
5. Wait for several seconds of the video to play (e.g. 10 sec), or seek forward ~1 minute, and then exit fullscreen (either by clicking the button or by using the Esc key).

Expected results:
Player exits fullscreen, and video continues to play from its current position.

Actual results:
Player exits fullscreen, but video starts all over again. Sometimes you even get an additional ad before the video restarts.

As I've said, this also affects Chrome in the exact same way.
I've seen the YouTube reload issue on exit fullscreen. This has been around for quite some time but that certainly looks like something YouTube is doing. We've definitely fixed a lot of crashes since you reported the issue. Are you OK with closing it?
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #12)
> I've seen the YouTube reload issue on exit fullscreen. This has been around
> for quite some time but that certainly looks like something YouTube is
> doing. We've definitely fixed a lot of crashes since you reported the issue.
> Are you OK with closing it?

Yes, I'm OK with closing both this and bug 1135052 since I wasn't able to reproduce them anymore. We'll look to try various YouTube issues also on other browsers (like Chrome) to distinguish between YouTube issues and Firefox issues.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.