Last Comment Bug 1000686 - Unpref Media Source Extensions (for WebM) in non-release builds.
: Unpref Media Source Extensions (for WebM) in non-release builds.
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
-- normal with 10 votes (vote)
: mozilla36
Assigned To: cajbir (:cajbir)
:
: Maire Reavy [:mreavy] Please needinfo me
Mentors:
Depends on: 77992 1002297 1024858 1025768 1025770 1028642 1028742 1031532 1040550 1041374 1041396 1044498 1061007 1062017 1089480 1089724 1089937 1092932 1135062
Blocks: 881512 942130 1031121 1037305 1067558 youtube-mse
  Show dependency treegraph
 
Reported: 2014-04-23 21:23 PDT by Matthew Gregan [:kinetik]
Modified: 2015-04-02 11:36 PDT (History)
33 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Unpref-Media-Source-Extensions-for-We.patch (1.72 KB, patch)
2014-04-23 21:25 PDT, Matthew Gregan [:kinetik]
no flags Details | Diff | Splinter Review
bug1000686_v1.patch (6.79 KB, patch)
2014-04-25 20:12 PDT, Matthew Gregan [:kinetik]
no flags Details | Diff | Splinter Review
bug1000686_p2_v2.patch (6.02 KB, patch)
2014-04-27 17:17 PDT, Matthew Gregan [:kinetik]
no flags Details | Diff | Splinter Review
bug1000686_v2.patch (6.02 KB, patch)
2014-04-27 18:38 PDT, Matthew Gregan [:kinetik]
no flags Details | Diff | Splinter Review
1000686.patch (958 bytes, patch)
2014-10-23 15:47 PDT, cajbir (:cajbir)
ajones: review+
Details | Diff | Splinter Review

Description User image Matthew Gregan [:kinetik] 2014-04-23 21:23:43 PDT
Spinning this off from a patch in bug 881512 to track it separately since the current plan is to land this change later than the other patches.
Comment 1 User image Matthew Gregan [:kinetik] 2014-04-23 21:25:48 PDT
Created attachment 8411549 [details] [diff] [review]
Unpref-Media-Source-Extensions-for-We.patch

Carrying over cajbir's review from bug 881512.
Comment 2 User image Matthew Gregan [:kinetik] 2014-04-23 22:03:50 PDT
To land this, also need a patch to update dom/tests/mochitest/general/test_interfaces.html for MediaSource, SourceBuffer, SourceBufferList, VideoPlaybackQuality.

Also should (have already) email an intent to implement, and possibly an intent to ship: https://wiki.mozilla.org/WebAPI/ExposureGuidelines#Intent_to_Implement and https://wiki.mozilla.org/WebAPI/ExposureGuidelines#Intent_to_Ship.  It's not clear if the intent to ship is needed until the RELEASE_BUILD ifdef is removed, but I strongly suspect not.
Comment 3 User image Matthew Gregan [:kinetik] 2014-04-24 00:43:53 PDT
Also need to change the test in content/media/mediasource/test/test_MediaSource.html.
Comment 5 User image Matthew Gregan [:kinetik] 2014-04-27 17:15:45 PDT
I landed the MIME whitelist part early, because I don't want to have to deal with a bunch of MSE bugs in the MP4 handling code that we're not ready to deal with yet.

https://hg.mozilla.org/integration/mozilla-inbound/rev/bc6a9d65b84f
Comment 6 User image Matthew Gregan [:kinetik] 2014-04-27 17:17:10 PDT
Created attachment 8413454 [details] [diff] [review]
bug1000686_p2_v2.patch

This is the rest of the patch.  Carrying forward r+ from cajbir and smaug.
Comment 7 User image Matthew Gregan [:kinetik] 2014-04-27 18:36:50 PDT
(In reply to Matthew Gregan [:kinetik] from comment #5)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/bc6a9d65b84f

Merged to m-c:

(In reply to Matthew Gregan [:kinetik] from comment #48)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #47)
> > https://hg.mozilla.org/mozilla-central/rev/bc6a9d65b84f
> 
> Oops, that's actually for bug 1000686, but I forgot to fix the commit
> message when splitting the bugs.
Comment 8 User image Matthew Gregan [:kinetik] 2014-04-27 18:38:33 PDT
Created attachment 8413476 [details] [diff] [review]
bug1000686_v2.patch

Identical to previous patch, except the commit message has been fixed to point to this bug.
Comment 9 User image John Drinkwater (:beta) 2014-09-11 06:25:28 PDT
Seeing the behaviour described in Bug 1024858, though that is marked Resolved. Can’t
Comment 10 User image Matthew Gregan [:kinetik] 2014-09-17 23:12:11 PDT
(In reply to John Drinkwater (:beta) from comment #9)
> Seeing the behaviour described in Bug 1024858, though that is marked
> Resolved. Can’t

Please retest with a current nightly, it should work better, although there are still bugs outstanding (see list of bugs this bug depends on).
Comment 11 User image Achwaq Khalid 2014-09-25 06:50:42 PDT
See: https://bugzilla.mozilla.org/show_bug.cgi?id=1060406
Comment 12 User image cajbir (:cajbir) 2014-10-23 15:47:40 PDT
Created attachment 8510663 [details] [diff] [review]
1000686.patch

Patch enables MSE for non-release builds.
Comment 13 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-10-23 19:33:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/918f4681e3f0
Comment 14 User image cajbir (:cajbir) 2014-10-24 01:47:02 PDT
Remaining open dependant bugs moved to bug 1088553.
Comment 15 User image Carsten Book [:Tomcat] 2014-10-24 06:55:12 PDT
https://hg.mozilla.org/mozilla-central/rev/918f4681e3f0
Comment 16 User image Leman Bennett [Omega] 2014-10-25 16:09:12 PDT
Was this wise? YouTube still has playback issues with WebM. None of them are tracked in the YouTube-MSE bug.
Comment 17 User image Achwaq Khalid 2014-10-25 16:39:57 PDT
I don't know about you guys but i'm still facing several issues with the YouTube HTML5 player too (Video totally freezing, buffer stops when i'm fast-forwarding or scrolling, comment section not loading and so on.......) these issues tend to be less severe when Adblock plus is disabled BTW
Comment 18 User image cajbir (:cajbir) 2014-10-26 00:11:27 PDT
(In reply to Leman Bennett [Omega] from comment #16)
> Was this wise? YouTube still has playback issues with WebM. None of them are
> tracked in the YouTube-MSE bug.

If they are not tracked, we don't know about them. Please raise bugs or describe the issues, with links to videos, so we can track them down.

Note You need to log in before you can comment on or make changes to this bug.