Closed Bug 1135067 Opened 5 years ago Closed 5 years ago

Name and phone number gets moved to the left once you hang up a call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jlorenzo, Assigned: thills)

Details

(Keywords: regression, Whiteboard: [planned-sprint c=1])

Attachments

(1 file)

STR
1. Place a call to either a known contact or an unknown one.
2. Hang up

Actual result
The name and the state of the call gets moved to the left by about 20 pixels.
[Blocking Requested - why for this release]: Visible regression which can be seen by every user.

QA wanted to check 2.2 and to get a video.
blocking-b2g: --- → 3.0?
status-b2g-v2.2: --- → ?
Keywords: qawanted
This issue does NOT occur on Flame 2.2 KK.

Actual Results: The Contact Name/Number and call state remain where they are when the call is hung up.
Environmental Variables:
Device: Flame 2.2
BuildID: 20150220073201
Gaia: 2b694a5a332495f1b9db06253690a2f5a702ed80
Gecko: 5c20fbeb5f8b
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: jmercado
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
The changes for Bug 1126374 seem to be the cause of this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150219101843
Gaia: 1c2fb4e76bc879cbb85c2390b8dc7456b3a8e478
Gecko: 871f0fbe15e3
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150219131410
Gaia: d4c3af78cd948f5965c2fa29a5fdfb5c00ae10ce
Gecko: 64a555d9d100
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 1c2fb4e76bc879cbb85c2390b8dc7456b3a8e478
Gecko: 64a555d9d100

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: d4c3af78cd948f5965c2fa29a5fdfb5c00ae10ce
Gecko: 871f0fbe15e3

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/1c2fb4e76bc879cbb85c2390b8dc7456b3a8e478...d4c3af78cd948f5965c2fa29a5fdfb5c00ae10ce
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Tamara, can you take a look at this please? Looks like the landing for bug 1126374 might have caused this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(thills)
Triage: It seems that the regressions was landed in a patch which will be uplifted to 2.2. Tamara, can you confirm that? If so, we'll nominate this issue to 2.2.
Whiteboard: [planned-sprint c=?]
Target Milestone: --- → 2.2 S7 (6mar)
Assignee: nobody → thills
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
Hi Johan/KTucker,

Yes, I found the problem and it is due to bug 1126374.  Thanks for tracking this regression down.

I'm working on a patch.

-tamara
Flags: needinfo?(thills)
Per Tamara's last comment, nominating to 2.2
blocking-b2g: 3.0? → 2.2?
Triage: Identifiable regression on a standard use case.
blocking-b2g: 2.2? → 2.2+
Attachment #8568609 - Flags: review?(drs.bugzilla)
Status: NEW → ASSIGNED
Did you try this in LTR mode? Does it work there?
Flags: needinfo?(thills)
Hi Doug,

Yes, this fixes ltr mode.

Thanks,

-tamara
Flags: needinfo?(thills)
Attachment #8568609 - Flags: review?(drs.bugzilla) → review+
Comment on attachment 8568609 [details] [review]
[gaia] tamarahills:bugfix/1135067-rtl-text-shifts-after-hangup > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1126374
[User impact] if declined: User will see a shift in the text of 20px when they hang up
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): Low.  CSS changes only.
[String changes made]: None
Attachment #8568609 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8568609 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual results: The name and status do not shift when a call is ended.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150309010232
Gaia: fea83511df9ccba64259346bc02ebf2c417a12c2
Gecko: eab4a81e4457
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150309002506
Gaia: 166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko: 91b7aa6a3243
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.