Search field should be larger at tablet width so text is not truncated

RESOLVED FIXED

Status

Marketplace
Consumer Pages
P4
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cvan, Assigned: atiqueahmedziad)

Tracking

Avenir
Points:
---

Details

(Whiteboard: [good first bug], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
1. Load a Marketplace page at tablet width (< 700px).
2. Notice the search placeholder text reads "Search the Market…" - the search box should be larger enough to accommodate the rest of the text (there's sufficient room).

https://marketplace.firefox.com/app/zirma
https://www.dropbox.com/s/r9i614h91hxn819/Screenshot%202015-02-20%2010.09.04.png?dl=0

Updated

3 years ago
Priority: -- → P4
Whiteboard: [good first bug]
(Assignee)

Comment 1

3 years ago
I want to fix it :) 
need help
Flags: needinfo?(amckay)

Comment 2

3 years ago
You've got the front end of the Marketplace setup, since you've already sent in a pull request on fireplace? So is your question about how to fix it? If so, it looks like the width is set to 230px in the CSS:

https://github.com/mozilla/fireplace/blob/650705daa7a2eb7c74ff4b065b81b6228ed04152/src/media/css/header.styl#L94-L104

This should be reproducible in the firefox developer tools, using responsive design view:

https://developer.mozilla.org/en/docs/Tools/Responsive_Design_View
Flags: needinfo?(amckay)
(Assignee)

Comment 3

3 years ago
Created attachment 8581454 [details] [review]
pull request

Please review
Attachment #8581454 - Flags: review?(amckay)

Updated

3 years ago
Attachment #8581454 - Flags: review?(amckay) → review+

Comment 4

3 years ago
https://github.com/mozilla/fireplace/pull/1092

Thanks Atique for that fix!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Assignee: nobody → softfilebd
You need to log in before you can comment on or make changes to this bug.