html5 youtube videos don't start most of the time

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
major
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: justdave, Unassigned)

Tracking

(Blocks: 1 bug)

37 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0

I've been told on IRC that this is a known issue, however, it's been doing this for a month or two and still hasn't been fixed, and now that I'm actually looking, I can't find a bug for it, so I'm filing one.

Probably about 60 to 70% of the time, loading any Youtube URL fails to start the video on the first page load.  Reloading the page anywhere from twice to 15 times will get the video to start eventually.

Example URL: https://www.youtube.com/watch?v=-CgUDVC9ysQ

Only happens when YouTube serves the video in html5 mode.  If it serves flash it plays right away, assuming flash is enabled.
Dave: is this bug related to e10s? The bug summary includes "[e10s]", but your description didn't mention e10s. The User-Agent string in your description says Firefox/37.0, which is Aurora and e10s auto-disables itself on non-Nightly channels.

Do you have any add-ons installed? I often have rebuffering hangs when skipping ahead in YouTube videos, but I m unable to reproduce the loading problem you are seeing. I tested Aurora 37 and Nightly 38 on OS X 10.10.
Blocks: 778617
tracking-e10s: --- → ?
Flags: needinfo?(justdave)
When you say "fails to start" do you mean it doesn't autoplay, or that it won't start even if you manually click the play button?
It won't start even if I click the Play button.

It's also gotten worse the last two days, I can no longer get Youtube videos to play at all (at least I've given up after hitting reload 30 or 40 times).
Flags: needinfo?(justdave)
(In reply to Chris Peterson [:cpeterson] from comment #1)
> Dave: is this bug related to e10s? The bug summary includes "[e10s]", but
> your description didn't mention e10s. The User-Agent string in your
> description says Firefox/37.0, which is Aurora and e10s auto-disables itself
> on non-Nightly channels.

I might be mixing up my terminology, I meant to refer to the playback mechanism being used by Youtube in HTML5 mode. If that's not what that is, remove it from the summary.

> Do you have any add-ons installed? I often have rebuffering hangs when
> skipping ahead in YouTube videos, but I m unable to reproduce the loading
> problem you are seeing. I tested Aurora 37 and Nightly 38 on OS X 10.10.

Yeah, a few, let me play with disabling a few and see what happens.
It does buffer the video - I can see the bar going across at the bottom as it loads the video. It just never plays.  (and until the last day or so it usually would if I reloaded a few times)
OK, I have every extension disabled now, and it still doesn't work.  However, starting up with a fully clean profile, it does work.  I must have a broken preference somewhere?  What preference items would be related?
Summary: [e10s] html5 youtube videos don't start most of the time → html5 youtube videos don't start most of the time
OK, after much experimenting, it looks like Youtube busted this themselves somehow.  Deleting a cookie from youtube.com called VISITOR_INFO1_LIVE fixed it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
cpearce: are you familiar with YouTube's VISITOR_INFO1_LIVE cookie? It would be nice to know how or why YouTube might intermittently break video playback based on some user state in a cookie.

I have a VISITOR_INFO1_LIVE cookie but its content is an opaque blob.
tracking-e10s: ? → ---
Flags: needinfo?(cpearce)
Sorry no, I am not familiar with that cookie.
Flags: needinfo?(cpearce)
Duplicate of this bug: 1135566
You need to log in before you can comment on or make changes to this bug.