ssltunnel is not running on b2g emulator

RESOLVED DUPLICATE of bug 1146713

Status

Testing
Mochitest
RESOLVED DUPLICATE of bug 1146713
3 years ago
3 years ago

People

(Reporter: mt, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
ssltunnel is not running on b2g emulator as a result of bug 1096197.

http://ftp.mozilla.org/pub/mozilla.org/b2g/try-builds/martin.thomson@gmail.com-3839dfc40da4/try-emulator/try_ubuntu64_vm-b2g-emulator_test-mochitest-6-bm51-tests1-linux64-build20.txt.gz

---

21:39:29     INFO -  MochitestServer : launching [u'/builds/slave/test/build/xre/bin/xpcshell', '-g', '/builds/slave/test/build/xre/bin', '-v', '170', '-f', '/builds/slave/test/build/xre/bin/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpjWymzS'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '10.0.2.2'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/builds/slave/test/build/tests/mochitest/server.js']
21:39:29     INFO -  runtests.py | Server pid: 5875
21:39:29     INFO -  runtests.py | Websocket server pid: 5877
21:39:29     INFO -  runtests.py | SSL tunnel pid: 5879
21:39:29     INFO -  Error: keyword "failHandshake" unexpected
21:39:29     INFO -  Error: config file "/tmp/ssltunnelTdVoFy.cfg" missing or formating incorrect
21:39:29     INFO -  Specify path to the config file as parameter to ssltunnel or
21:39:29     INFO -  create ssltunnel.cfg in the working directory.

---

bug 1100917 might also be a problem even if this is fixed, since that also added new directives to the configuration file.  But I note that a workaround was added that bug 1111188 was opened to address, I'm not sure whether that is sufficient. 

Best plan is (probably) to update the hostutils (again).  :jmaher might know what to do.
(Reporter)

Updated

3 years ago
Blocks: 995328
Is this the reason why I can't get ./mach mochitest-remote not working? (using emulator-kk)
Why isn't this a problem on treeherder machines?
Flags: needinfo?(jmaher)
Created attachment 8567680 [details]
error.txt

This is the error I get, while trying to run a mochitest-remote mochitest.
(Reporter)

Comment 3

3 years ago
That one is relatively easy to address.  You should be able to update the version of gecko that runs on the host machine by picking a new version here: https://github.com/mozilla-b2g/gaia/blob/master/Makefile#L304-L305

That's probably something that needs to be addressed too.
Flags: needinfo?(jmaher)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146713
You need to log in before you can comment on or make changes to this bug.