Closed Bug 113549 Opened 21 years ago Closed 21 years ago

Site hangs mozilla (Unix font code)

Categories

(Core :: Layout, defect)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED WORKSFORME
mozilla0.9.9

People

(Reporter: hippytrail, Assigned: bstell)

References

()

Details

(Keywords: crash, hang)

The given URL causes Mozilla and Nautilus to crash but not Old Netscape nor
Lynx.  It may be a gecko problem?
I can view the page by Mozilla0.9.6/Linux and 2001120206/Linux.
But when I went to the URL, Mozilla didn't response in a few seconds.(100% CPU load)
After that, the page was displayed.
got no crash but it took almost two minutes to render a page with not much text.
P3/500, ADSL1024Kbps)

There maye be some CSS oddities going on there:
The blue text content seems to be the problem and takes longest time to load.
Every second the text is selected with cursor, fontface and size change. The
effect can partly be seen when scrolling the page too.

Testing with a Linux CVS from the 6th.
hippietrail@yahoo.com, are you actually seeing a crash (all browser windows 
suddenly disappear)?  If so, could you please use a talkback-enabled build to 
test this site and report the incident ID in this bug?

If you are not in fact seeing a crash, are you seeing a hang (browser windows 
stay, but are unresponsive)?  If so, does waiting a few minutes make the browser 
responsive again?

What sort of hardware (RAM and CPU) do you have?
I was seeing a crash, not a hang. But I do not currently have access to the same
system.
I have a habit of testing Mozilla on every computer I find while travelling
around the world (:  The crash was on a RedHat 7.2 box.  I currently have access
to a Power Macintosh 7300/200, MacOS 9.04, Mozilla Build 2001122106.  On this
system the URL works quickly and flawlessly.  Maybe it's now fixed?
no longer a crash. morphing bug into a hang (possibly) in css. 

tested with 0.9.7 linux build. 
Assignee: asa → dbaron
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
QA Contact: doronr → ian
Summary: Site crashes browser → Site hangs mozilla (possibly in css)
Assignee: dbaron → attinasi
Component: Style System → Layout
QA Contact: ian → petersen
Summary: Site hangs mozilla (possibly in css) → Site hangs mozilla (Unix font code)
I'm seeing various sorts of hangs here, but the problems seem to be in the font
code.  I'm seeing lots of time spent within nsFontMetricsGTK::FindFont, and
assertions like these:

###!!! ASSERTION: failed to get converter type: 'mDocConverterType!=nsnull',
file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp, line 4114
###!!! Break: at file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp,
line 4114
###!!! ASSERTION: mFontHolder should not be loaded: '!mFontHolder', file
/builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp, line 2010
###!!! Break: at file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp,
line 2010
###!!! ASSERTION: mFontHolder should not be loaded: '!mFontHolder', file
/builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp, line 2010
###!!! Break: at file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp,
line 2010
###!!! ASSERTION: mFontHolder should not be loaded: '!mFontHolder', file
/builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp, line 2010
###!!! Break: at file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp,
line 2010
> ###!!! ASSERTION: failed to get converter type: 'mDocConverterType!=nsnull',
> file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp, line 4114
> ###!!! Break: at file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp,
> line 4114

This is minor and I should remove the assertion.

> ###!!! ASSERTION: mFontHolder should not be loaded: '!mFontHolder', file
> /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp, line 2010
> ###!!! Break: at file /builds/trunk/mozilla/gfx/src/gtk/nsFontMetricsGTK.cpp,
> line 2010

I do not think this is a problem but I will look at it.

Assignee: attinasi → bstell
I opened bug 118033 to clean up the assertion
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
cannot reproduce this with my trunk build. mark it work for me. Please verify it.
reopen if you still can reproduce it.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Keywords: crash, hang, nsbeta1
Resolution: --- → WORKSFORME
if reopen, please reassign to shanjian
On a 15 h. old trunk build/P3/500, Linux:

Mozilla just had a CPU intensive freeze for 5 minutes trying to load the page,
xfs and mozilla-bin struggling to use 100% each.
I don't usually go to sites that use asian fonts, so it doesn't matter to me
personally. Just wanted to point out that there is still an extreme performance
issue here.
This problem is not occuring in the April 16th Linux build (2002-04-16-09).
Status: RESOLVED → VERIFIED
still seeing the hang in a day old cvs build, linux.
You need to log in before you can comment on or make changes to this bug.