Closed Bug 1135885 Opened 5 years ago Closed 5 years ago

Animate transition to editing mode

Categories

(Firefox for iOS :: Browser, defect)

All
iOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: wesj, Assigned: bmunar)

References

Details

Attachments

(1 file)

PR
47 bytes, text/x-github-pull-request
wesj
: review+
Details | Review
We should make this transition to editing mode feel smoother.
is this also done?
Flags: needinfo?(wjohnston)
Isn't there already a transition?
The BrowserLocationView doesn't actually transition. i.e. the lock/readingmode/etc. icons just disappear. The textfield also doesn't dynamically resize itself (it just jumps to the new size). Now that there's only one textbox here instead of two that we're switching between, this shouldn't be too hard.
Flags: needinfo?(wjohnston)
Was just about to file a regression and found this bug. Nom-ing it because the textfield width actually used to animate with the same duration and easing as the rest of the layout changes – this should still happen.
tracking-fxios: --- → ?
Component: General → Browser
OS: Mac OS X → iOS
Hardware: x86 → All
Assignee: nobody → bmunar
Attached file PR
Attachment #8633692 - Flags: review?(dhenein)
Attachment #8633692 - Flags: review?(dhenein) → review?(wjohnston)
Comment on attachment 8633692 [details] [review]
PR

I'd believe that
Attachment #8633692 - Flags: review?(wjohnston) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.