[Text Selection] The carets overlap with utility bubble when the selected text is closed to top of device

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gchang, Assigned: gduan)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
### Steps:
1. Open Browser app
2. Type any words in search bar, ex: "google map"
3. Select non-url characters in the page
4. Scroll up the screen until the selected word is closed to the top
5. Watch the positions of utility bubble and carets. The carets should be above of the utility bubble.

### Actual:
1. The carets and utility bubble overlap

### Expected:
1. The carets and utility bubble should not overlap

### Reproduce rate
always

### Version:
Gaia-Rev        389542b71c89253c0d176d3b0bfb54e275c19bf1
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/81bcdde1e783
Build-ID        20150223162505
Version         37.0
Device-Name     flame
FW-Release      4.4.2
Reporter

Comment 1

4 years ago
NI UX to see if the utility bubble should overlap carets (because the water drop becomes larger).
Flags: needinfo?(ofeng)
Reporter

Comment 2

4 years ago
Posted image BZ1136041.png
Reporter

Updated

4 years ago
QA Whiteboard: [COM=Text Selection]
Assignee: nobody → gduan
@George, please move the bubble a little bit downward, thanks!
Flags: needinfo?(ofeng)
Comment on attachment 8569646 [details] [review]
[gaia] cctuan:1136041 > mozilla-b2g:master

Hi Alive,
since caret's size has been enlarged, we need to change the position of bubble. And vd also request to have a margin between screen's boundary and bubble.

Please kindly check, thanks.
Attachment #8569646 - Flags: review?(alive)
Attachment #8569646 - Flags: review?(alive) → review+

Comment 6

4 years ago
Triage: blocking 2.2
blocking-b2g: --- → 2.2+
Thanks, 
https://github.com/mozilla-b2g/gaia/commit/ef6a7b7a9a3d2b4305c7d798481ccdbc99e09ac8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8569646 [details] [review]
[gaia] cctuan:1136041 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Not a regression nor a feature of gaia.
[User impact] if declined: Bubble might overlap the caret and cause bad user experience.
[Testing completed]: Yes. visual team has checked and also updated the unit test.
[Risk to taking this patch] (and alternatives if risky): No.
[String changes made]:
Attachment #8569646 - Flags: approval-gaia-v2.2?
Attachment #8569646 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed in the lates Nightly Flame 3.0 and 2.2 builds.

Actual Results: When text near the top of the screen is selected, the selection carats do not overlap with the copy paste icons.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150311110236
Gaia: 2b87ee8e7e2ec30a9851b6b59a899006a98767ab
Gecko: bc6aeea72290
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.