Closed Bug 1136067 Opened 5 years ago Closed 5 years ago

incorrect positioning of ruby in vertical writing-mode on B2G

Categories

(Core :: Layout, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jfkthame, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fixed by bug 1137588])

The reftest 1135361-ruby-justify-1.html fails on B2G, see https://tbpl.mozilla.org/?tree=Try&rev=6c37a39541ca.

In the reftest analyzer images, the ruby glyphs (in both the testcase and in the reference, which doesn't use justification) look like they're placed too high relative to the base character.

(Maybe this is caused by something about the metrics of the Japanese and Latin fonts that are being used in that case? If so, it might be reproducible on desktop by installing and selecting the same fonts B2G is using.)
Depends on: 1137588
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1137588]
You need to log in before you can comment on or make changes to this bug.