Text in vertical writing mode is lower than its containing inline box

RESOLVED FIXED in Firefox 39

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: xidorn, Assigned: jfkthame)

Tracking

(Blocks 1 bug)

Trunk
mozilla39
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(4 attachments)

Reporter

Description

4 years ago
Posted file testcase
See attachment. On Android and B2G, the position of the text in vertical writing mode is a little lower than the inline box containing it. It seems to happen only for upright characters.
Reporter

Updated

4 years ago
Attachment #8570326 - Attachment filename: ruby-vertical.html → span-vertical.html
Reporter

Comment 1

4 years ago
Posted image screenshot
Reporter

Comment 2

4 years ago
I suspect that this bug probably causes bug 1136067.
Blocks: 1136067
Assignee

Comment 3

4 years ago
Yes, that looks likely.

I wonder if this may also be related to the incorrect sizing described in bug 1137582. I'll try to look into this next week, when I'm back from PTO.
Reporter

Comment 4

4 years ago
Though bug 1137582 has been fixed, it seems this bug still exists.
Assignee

Comment 5

4 years ago
This appears to be an issue with particular fonts. I can reproduce a it on OS X desktop by explicitly using the Droid Sans Fallback font, for example, or MotoyaLMaru; but TakaoPGothic, in contrast, renders fine.
Assignee

Comment 6

4 years ago
Turns out there are two bugs here. First, gfxHarfBuzzShaper doesn't read 'vmtx' tables correctly -- it ignores the second (sidebearing-only) array, if present. Fixing this gives us correct results with fonts like MotoyaLMaru, which make use of the monospaced optimization.
Attachment #8582512 - Flags: review?(jdaggett)
Assignee

Updated

4 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Assignee

Comment 7

4 years ago
Second problem is that when no 'vmtx' table is present, we return a vertical origin based on the 'hhea' ascent, which is often too large because we're using the em height as the default advance. Adjusting this gives us a better result with fonts like Droid Sans Fallback that lack any 'vmtx' table.
Attachment #8582514 - Flags: review?(jdaggett)

Updated

4 years ago
Attachment #8582512 - Flags: review?(jdaggett) → review+

Updated

4 years ago
Attachment #8582514 - Flags: review?(jdaggett) → review+
https://hg.mozilla.org/mozilla-central/rev/44625300e010
https://hg.mozilla.org/mozilla-central/rev/986f5faf4655
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.