If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings][Privacy Controls] There is no way to "x" out of the Guided Tour on a few pages

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: DerekH, Assigned: marta)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(3 attachments)

Created attachment 8568668 [details]
Guided Tour Logcat

Description:
During the Guided Tour of the Privacy controls, there is seemingly random pages that are missing an "x" in the upper left corner, in order to dismiss the tour


Repro Steps:
1) Update a Flame to 20150224010314
2) Open Settings App> Privacy Controls
3) If the Guided Tour does not start, open the Guided Tour
4) Tap Get Started!> Tap "Next" 5 times, and observe top left corner


Actual:
There is no X on this page to dismiss the Guided tour. This also occurs on the 9th and 10th page of the Tour


Expected:
There is consistency in the Guided Tour, so there is either always a way to dismiss the tour, or no way to dismiss the tour until the end

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/51U1ZDr9oTc
This issue DOES occur on Flame 2.2

There is no X on this page to dismiss the Guided tour.

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
________________________________________________________________________________________

The Privacy controls did not exist in Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224002520
Gaia: 86af0ca427adad12c3109124f31bef2fd9614e47
Gecko: a275f2c05ca6
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Summary: [Settings][Privacy Controls] There is now way to "x" out of the Guided Tour on a few pages → [Settings][Privacy Controls] There is no way to "x" out of the Guided Tour on a few pages
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
Keywords: regression
Hi Marta,
This might need your help.
Blocks: 1057675
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Privacy Panel]
Flags: needinfo?(gchang) → needinfo?(marta)
(Assignee)

Comment 4

3 years ago
I will look at it
Assignee: nobody → marta
Flags: needinfo?(marta)

Updated

3 years ago
Status: NEW → ASSIGNED

Comment 5

3 years ago
Created attachment 8571025 [details] [review]
[gaia] martasect:Bug_1136286 > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8571025 [details] [review]
[gaia] martasect:Bug_1136286 > mozilla-b2g:master

Could you review?
Attachment #8571025 - Flags: review?(dharris)
Comment on attachment 8571025 [details] [review]
[gaia] martasect:Bug_1136286 > mozilla-b2g:master

This patch has fixed the issue on Flame 3.0

After uploading the patch to my device, there is an "x" on each page so the user can dismiss the guided tour at any point. 

Environmental Variables:
Device: Flame 3.0
Build ID: 20150302010223
Gaia: d2242b274968ac4188c0feae513e74557f2b0f9a
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Attachment #8571025 - Flags: review?(dharris) → review+

Updated

3 years ago
blocking-b2g: --- → 2.2+

Updated

3 years ago
Priority: -- → P2

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 8

3 years ago
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 9

3 years ago
What do I do here?
Flags: needinfo?(kgrandon)
Comment on attachment 8571025 [details] [review]
[gaia] martasect:Bug_1136286 > mozilla-b2g:master

Hmm, I'm not sure if the request of Derek was meant as a technical review of the code? In any case, we probably want to setup a proper component for privacy panel work, but for now I will leave my review and manually land this as it looks simple enough. Thanks!
Flags: needinfo?(kgrandon)
Attachment #8571025 - Flags: review+ → review+
In master: https://github.com/mozilla-b2g/gaia/commit/0c4e8b0b330757e261b031b7e7f326ef419c9808
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
This issue is verified fixed on the latest Nightly Flame 3.0 build.  Setting the verifyme tag so this gets checked if/when 2.2 gets fixed.

Actual Results: All pages of the Guided Tour had the 'x' button available.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Privacy Panel] → [QAnalyst-Triage?][COM=Privacy Panel]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][COM=Privacy Panel] → [QAnalyst-Triage+][COM=Privacy Panel]
Flags: needinfo?(ktucker)
Please request Gaia v2.2 on this when you get a chance.
Flags: needinfo?(marta)
Target Milestone: --- → 2.2 S8 (20mar)
(Assignee)

Comment 14

3 years ago
Comment on attachment 8571025 [details] [review]
[gaia] martasect:Bug_1136286 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1136286
[User impact] if declined: During the Guided Tour of the Privacy controls, there is seemingly random pages that are missing an "x" in the upper left corner, in order to dismiss the tour - user will not be able to exit the GT. 
[Testing completed]: YES
[Risk to taking this patch] (and alternatives if risky): low
Flags: needinfo?(marta)
Attachment #8571025 - Flags: approval-gaia-v2.2?(dietrich)

Updated

3 years ago
Attachment #8571025 - Flags: approval-gaia-v2.2?(dietrich) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/4d908bbb04c9a4af742161f38073cf5fcd36e708
status-b2g-v2.2: affected → fixed

Comment 16

3 years ago
Created attachment 8582118 [details]
verify_video.MP4

This issue has been verified successfully on Flame 2.2
STR:
1. Open Settings App> Privacy Controls.
2. If the Guided Tour does not start, open the Guided Tour.
3. Tap Get Started!> Tap "Next" button, and observe top left corner
**All pages of the Guided Tour had the 'x' button available.
See attachment:verify_video.MP4
Rate:0/5

Device: Flame 2.2(pass)
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+][COM=Privacy Panel] → [QAnalyst-Triage+][COM=Privacy Panel][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.