Style the LDAP info page in address book

RESOLVED FIXED in Thunderbird 39.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 39.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird38+ fixed, thunderbird39 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
Bug 170270 introduced in address book, when a LDAP AB is selected, a info page to inform there are only results shown when searched.

This bug is to style this page like the trees.
Assignee

Comment 1

4 years ago
Use -moz-field as background color and hide the splitter below.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8568727 - Flags: review?(josiah)

Comment 2

4 years ago
Screenshot of current patch would be nice
Assignee

Comment 3

4 years ago
There is no need for a screenshot. The patch gives this box only the same background color as the tree has. It looks then as the tree is empty with one centered message. On OS X and XP the splitter are thick and it is looking weird to show them below the message box without a function, so I hide them. On Linux and Win7+ the splitter is small but it's also better to hide them.

Comment 4

4 years ago
(In reply to Richard Marti (:Paenglab) from comment #3)
> There is no need for a screenshot. The patch gives this box only the same
> background color as the tree has.

Ok, thanks, sounds good. The tree on the left or on the right?
Assignee

Comment 5

4 years ago
On the right.

Updated

4 years ago
Depends on: 1136792

Updated

4 years ago
No longer depends on: 1136792
Comment on attachment 8568727 [details] [diff] [review]
LDAPBlankPage.patch

Review of attachment 8568727 [details] [diff] [review]:
-----------------------------------------------------------------

I don't have an LDAP address book, but the code looks fine. Assuming you have tested this on all three platforms, r+.

If not, please verify the results!
Attachment #8568727 - Flags: review?(josiah) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Pushed as https://hg.mozilla.org/comm-central/rev/a27f018cf6eb
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
TB 38?
Target Milestone: Thunderbird 38.0 → Thunderbird 39.0
Assignee

Comment 9

4 years ago
Comment on attachment 8568727 [details] [diff] [review]
LDAPBlankPage.patch

[Approval Request Comment]
Regression caused by (bug #): Not a regression but a new feature by bug 170270
User impact if declined: Wrong background color of message
Testing completed (on c-c, etc.): in c-c
Risk to taking this patch (and alternatives if risky): Low, only css change.
Attachment #8568727 - Flags: approval-comm-aurora?
Comment on attachment 8568727 [details] [diff] [review]
LDAPBlankPage.patch

Pushed as https://hg.mozilla.org/releases/comm-aurora/rev/0d48ec44636b
Attachment #8568727 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.