Closed Bug 1136359 Opened 5 years ago Closed 5 years ago

Backout Array.includes and String.includes usage in tab completion code

Categories

(Thunderbird :: Instant Messaging, defect)

x86
macOS
defect
Not set

Tracking

(thunderbird37 unaffected, thunderbird38 fixed)

RESOLVED FIXED
Thunderbird 39.0
Tracking Status
thunderbird37 --- unaffected
thunderbird38 --- fixed

People

(Reporter: aleth, Assigned: aleth)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 1134905 contained https://hg.mozilla.org/comm-central/rev/56cf0d1ed0a0, which switched to using Array.includes and String.includes. Both of these are however only enabled in nightlies at present, so we need to back it out from both TB and IB.
Attached patch noindexof-backout.diff (obsolete) — Splinter Review
Attachment #8568776 - Flags: review?(clokep)
Comment on attachment 8568776 [details] [diff] [review]
noindexof-backout.diff

Review of attachment 8568776 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for asking you to change it!

::: im/content/conversation.xml
@@ -1051,5 @@
>              // Keep only the completions that share |word| as a prefix.
>              // Be case insensitive only if |word| is entirely lower case.
>              let condition;
>              if (word.toLocaleLowerCase() == word)
> -              condition = c => c.toLocaleLowerCase().startsWith(word);

startsWith landed a few versions ago, I believe.
Attachment #8568776 - Flags: review?(clokep) → review-
(In reply to Patrick Cloke [:clokep] from comment #2)
> Comment on attachment 8568776 [details] [diff] [review]
> noindexof-backout.diff
> 
> Review of attachment 8568776 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Sorry for asking you to change it!
> startsWith landed a few versions ago, I believe.

That's true, but it's cleaner to back out the whole patch imho.
You can pry my startsWith from my cold, dead hands, etc.
Attachment #8568776 - Attachment is obsolete: true
Attachment #8569417 - Flags: review?(clokep)
Comment on attachment 8569417 [details] [diff] [review]
noindexof-backout.diff 2

Thanks! :)
Attachment #8569417 - Flags: review?(clokep) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
Comment on attachment 8569417 [details] [diff] [review]
noindexof-backout.diff 2

[Approval Request Comment]
Regression caused by (bug #): Bug 1134905
User impact if declined: tab completion failures
Risk to taking this patch (and alternatives if risky): none, this is a backout.
Attachment #8569417 - Flags: approval-comm-aurora?
Target Milestone: Thunderbird 38.0 → Thunderbird 39.0
Comment on attachment 8569417 [details] [diff] [review]
noindexof-backout.diff 2

https://hg.mozilla.org/releases/comm-aurora/rev/4880a53c711b
Attachment #8569417 - Flags: approval-comm-aurora? → approval-comm-aurora+
(In reply to Kent James (:rkent) from comment #8)
> https://hg.mozilla.org/releases/comm-aurora/rev/4880a53c711b

Thanks!
You need to log in before you can comment on or make changes to this bug.