WebGL 1.0.3 conformance error: conformance/context/context-lost.html

RESOLVED FIXED in Firefox 50

Status

()

RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: lukebenes, Assigned: jgilbert)

Tracking

(Blocks: 2 bugs)

39 Branch
mozilla50
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 fixed)

Details

(Whiteboard: webgl-conformance gfx-noted, URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

https://www.khronos.org/registry/webgl/sdk/tests/conformance/context/context-lost.html?webglVersion=1


Actual results:

FAIL getError expected: NO_ERROR. Was INVALID_OPERATION : after evaluating: OES_vertex_array_object.bindVertexArrayOES(vertexArrayObject)
FAIL getError expected: NO_ERROR. Was INVALID_OPERATION : after evaluating: OES_vertex_array_object.isVertexArrayOES(vertexArrayObject)
FAIL getError expected: NO_ERROR. Was INVALID_OPERATION : after evaluating: OES_vertex_array_object.deleteVertexArrayOES(vertexArrayObject)


Expected results:

Chrome passes all the tests. Firefox fails the test with both the ANGLE and OpenGL backends.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
(Assignee)

Updated

4 years ago
Whiteboard: webgl-conformance → webgl-conformance gfx-noted
(Reporter)

Updated

4 years ago
No longer blocks: 845345
Summary: WebGL conformance error: conformance/context/context-lost.html → WebGL 1.0.3 conformance error: conformance/context/context-lost.html

Comment 1

3 years ago
Tested several device configurations and reproduced this test to fail on all of them: SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-5, NEXUS-10, SURFACE, WINDBOX, HASWELL, HPOMEN (see https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems) , so this looks like a machine independent issue.
(Reporter)

Updated

3 years ago
Blocks: 1193526
(Assignee)

Updated

3 years ago
Blocks: 1246063
(Assignee)

Updated

3 years ago
No longer blocks: 1193526
(Assignee)

Updated

3 years ago
Blocks: 1246065
(Assignee)

Updated

3 years ago
Assignee: nobody → jgilbert

Comment 2

3 years ago
Created attachment 8738898 [details] [diff] [review]
Remove operation error.

May I just simply remove the operation errors?
Attachment #8738898 - Flags: review?(jgilbert)
(Assignee)

Comment 3

3 years ago
Comment on attachment 8738898 [details] [diff] [review]
Remove operation error.

Review of attachment 8738898 [details] [diff] [review]:
-----------------------------------------------------------------

The spec is ambiguous. I will get clarification.
Attachment #8738898 - Flags: review?(jgilbert)
(Assignee)

Comment 5

3 years ago
The clarification is that we should follow the steps in "5.14.14 Detecting and enabling extensions".
(Assignee)

Comment 6

3 years ago
(In reply to Jeff Gilbert [:jgilbert] from comment #5)
> The clarification is that we should follow the steps in "5.14.14 Detecting
> and enabling extensions".

I got this backwards. Prefer the steps in 5.14 to those in 5.14.14.
(Assignee)

Comment 7

3 years ago
Comment on attachment 8738898 [details] [diff] [review]
Remove operation error.

Review of attachment 8738898 [details] [diff] [review]:
-----------------------------------------------------------------

Let's fix this properly.

We need to remove WebGLExtensionBase::mIsLost, and update all the extensions to support the process listed in 5.14 from the WebGL 1 spec.
Attachment #8738898 - Flags: review-

Comment 8

2 years ago
Retested this today on my HASWELL PC with

Windows 10 Home 64-bit
3.0 GHz Intel 8-Core i7-5960X
32GB of RAM
3840x2160 pixels display

SLI 2x ASUS NVIDIA GeForce GTX 980 Ti, 4+4GB of VRAM, driver version 365.19
	- nvd3dumx.dll, nvwgf2umx.dll:
		- version 10.18.13.6191
		- date 2/8/2016
		- D3D Version 12.1, WDDM 2.0, WHQL approved

with Firefox Nightly 50.0a1 (2016-06-19), and I see the failure still occurs. Looks like the above patch has not yet made its way in?
(Reporter)

Updated

2 years ago
OS: Windows 7 → All
(Assignee)

Comment 9

2 years ago
Created attachment 8772236 [details]
Bug 1136416 - Hack to pass the context-lost test for now. -

Review commit: https://reviewboard.mozilla.org/r/65092/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/65092/
Attachment #8772236 - Flags: review?(ethlin)
(Assignee)

Comment 10

2 years ago
I have patches to fix this properly, but it's under-specced, so I'm going to nail down the spec first before doing reviews.

Comment 11

2 years ago
Comment on attachment 8772236 [details]
Bug 1136416 - Hack to pass the context-lost test for now. -

https://reviewboard.mozilla.org/r/65092/#review62160

It looks fine to pass the test for now.
Attachment #8772236 - Flags: review?(ethlin) → review+

Comment 13

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fef2ed0327d5
https://hg.mozilla.org/mozilla-central/rev/bdf984d32e47
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.