Closed Bug 1136494 Opened 5 years ago Closed 4 years ago

WebGL 1.0.3 conformance/renderbuffers/feedback-loop.html

Categories

(Core :: Canvas: WebGL, defect)

39 Branch
x86_64
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: lukebenes, Assigned: jgilbert)

References

(Blocks 1 open bug)

Details

(Whiteboard: webgl-conformance gfx-noted)

Attachments

(7 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

https://www.khronos.org/registry/webgl/sdk/tests/conformance/renderbuffers/feedback-loop.html?webglVersion=1


Actual results:

conformance/renderbuffers/feedback-loop.html (7 of 9 passed)

    failed: getError expected: INVALID_OPERATION. Was NO_ERROR : after draw with invalid feedback loop
    failed: at (0, 0) expected: 0,0,255,255 was 0,255,0,255


Expected results:

Chrome passes all the tests. Firefox fails with both the ANGLE and OpenGL backends.
Environment: Win 7 64-bit
Reproduced with Nightly 39.0a1 2015-02-25 (2 fails); no fails using Google Chrome Version 40.0.2214.115 m.
Status: UNCONFIRMED → NEW
Component: Untriaged → Canvas: WebGL
Ever confirmed: true
Product: Firefox → Core
Whiteboard: webgl-conformance → webgl-conformance gfx-noted
No longer blocks: webgl-1.0.2
Summary: conformance/renderbuffers/feedback-loop.html → WebGL 1.0.3 conformance/renderbuffers/feedback-loop.html
This is most likely fixed when https://bugzilla.mozilla.org/show_bug.cgi?id=936739 is implemented(?)
This test was reproduced to fail on the following tested devices:
 - SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-5, NEXUS-10, SURFACE, WINDBOX, HPOMEN

See https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems.
Blocks: 1193526
Blocks: webgl-103
No longer blocks: 1193526
Depends on: 1251487
I will study this.
Assignee: nobody → ethlin
Assignee: ethlin → nobody
Retested this today on my HASWELL PC with

Windows 10 Home 64-bit
3.0 GHz Intel 8-Core i7-5960X
32GB of RAM
3840x2160 pixels display

SLI 2x ASUS NVIDIA GeForce GTX 980 Ti, 4+4GB of VRAM, driver version 365.19
	- nvd3dumx.dll, nvwgf2umx.dll:
		- version 10.18.13.6191
		- date 2/8/2016
		- D3D Version 12.1, WDDM 2.0, WHQL approved

with Firefox Nightly 50.0a1 (2016-06-19), and I see the failure still occurs.
OS: Windows 7 → All
Assignee: nobody → jgilbert
Review commit: https://reviewboard.mozilla.org/r/64320/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/64320/
Attachment #8771058 - Flags: review?(mtseng)
Attachment #8771059 - Flags: review?(mtseng)
Attachment #8771060 - Flags: review?(mtseng)
Attachment #8771061 - Flags: review?(mtseng)
Attachment #8771062 - Flags: review?(mtseng)
Attachment #8771063 - Flags: review?(mtseng)
Comment on attachment 8771058 [details]
Bug 1136494 - Try to pull <windows.h> include out of GLContext.h. -

https://reviewboard.mozilla.org/r/64320/#review61478
Attachment #8771058 - Flags: review?(mtseng) → review+
Comment on attachment 8771059 [details]
Bug 1136494 - Update LinkInfo. -

https://reviewboard.mozilla.org/r/64322/#review61514

::: dom/canvas/WebGLProgram.cpp:119
(Diff revision 1)
> -    activeInfoList->push_back(info);
> +    }
>  }
>  
> -//#define DUMP_SHADERVAR_MAPPINGS
> +//////////
> +
> +#define DUMP_SHADERVAR_MAPPINGS

Do we need turn on this debug flag?
Attachment #8771059 - Flags: review?(mtseng) → review+
Comment on attachment 8771063 [details]
Bug 1136494 - Validate mActiveProgramLinkInfo in ScopedResolveTexturesForDraw, since it's run first. -

https://reviewboard.mozilla.org/r/64330/#review61536
Attachment #8771063 - Flags: review?(mtseng) → review+
https://reviewboard.mozilla.org/r/64322/#review61514

> Do we need turn on this debug flag?

Nope.
Duplicate of this bug: 1251487
Blocks: 1286768
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c35da4f57e6
Try to pull <windows.h> include out of GLContext.h. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/b78045c38ca2
Update LinkInfo. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a13fc6c82c4
Update post-link validation. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/be7d2dd9f84f
Add WebGLTexture::IsFeedback. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/d13fc4592665
Update uniform setters. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/34b7d622c520
Validate mActiveProgramLinkInfo in ScopedResolveTexturesForDraw, since it's run first. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/37a5b78f9a9d
Update test markings.
You need to log in before you can comment on or make changes to this bug.