Closed Bug 1136508 Opened 5 years ago Closed 3 years ago

WebGL 1.0.3 conformance error: conformance/textures/texture-copying-feedback-loops.html

Categories

(Core :: Canvas: WebGL, defect)

39 Branch
x86_64
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: lukebenes, Assigned: jgilbert)

References

(Blocks 1 open bug)

Details

(Whiteboard: webgl-conformance gfx-noted)

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

https://www.khronos.org/registry/webgl/sdk/tests/conformance/textures/texture-copying-feedback-loops.html?webglVersion=1


Actual results:

conformance/textures/texture-copying-feedback-loops.html (7 of 9 passed)

    failed: getError expected: INVALID_OPERATION. Was NO_ERROR : after copyTexImage2D to same texture same level, invalid feedback loop
    failed: getError expected: INVALID_OPERATION. Was NO_ERROR : after copyTexSubImage2D to same texture same level, invalid feedback loop


Expected results:

Chrome passes all the tests. Firefox fails with both the ANGLE and OpenGL backends.
Summary: conformance/textures/texture-copying-feedback-loops.html → WebGL conformance error: conformance/textures/texture-copying-feedback-loops.html
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Whiteboard: webgl-conformance → webgl-conformance gfx-noted
No longer blocks: webgl-1.0.2
Summary: WebGL conformance error: conformance/textures/texture-copying-feedback-loops.html → WebGL 1.0.3 conformance error: conformance/textures/texture-copying-feedback-loops.html
This was tested to fail independent of hardware:
 - SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-5, NEXUS-10, SURFACE, WINDBOX, HASWELL, HPOMEN

See https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems.

The root cause for this failure is likely a missing implementation from https://bugzilla.mozilla.org/show_bug.cgi?id=936739 .
Blocks: 1193526
Blocks: webgl-103
No longer blocks: 1193526
Depends on: 1251487
I will try to fix it.
Assignee: nobody → ethlin
Detect the feedback loop and report error.
Assignee: ethlin → nobody
Retested this today on my HASWELL PC with

Windows 10 Home 64-bit
3.0 GHz Intel 8-Core i7-5960X
32GB of RAM
3840x2160 pixels display

SLI 2x ASUS NVIDIA GeForce GTX 980 Ti, 4+4GB of VRAM, driver version 365.19
	- nvd3dumx.dll, nvwgf2umx.dll:
		- version 10.18.13.6191
		- date 2/8/2016
		- D3D Version 12.1, WDDM 2.0, WHQL approved

with Firefox Nightly 50.0a1 (2016-06-19), and I see the failure still occurs.
OS: Windows 7 → All
Assignee: nobody → jgilbert
Comment on attachment 8770437 [details]
Bug 1136508 - Detect CopyTexImage feedback loops. -

https://reviewboard.mozilla.org/r/63892/#review60952
Attachment #8770437 - Flags: review?(mtseng) → review+
Comment on attachment 8770438 [details]
Bug 1136508 - Remove redundent READ_BUFFER != NONE validation. -

https://reviewboard.mozilla.org/r/63894/#review60954
Attachment #8770438 - Flags: review?(mtseng) → review+
Comment on attachment 8770439 [details]
Bug 1136508 - Removed unused READ_BUFFER out-var from ValidateCurFBForRead. -

https://reviewboard.mozilla.org/r/63896/#review60956
Attachment #8770439 - Flags: review?(mtseng) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/190fa9a5f989
Detect CopyTexImage feedback loops. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/13d68716249b
Remove redundent READ_BUFFER != NONE validation. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/1620c8f330a3
Removed unused READ_BUFFER out-var from ValidateCurFBForRead. - r=mtseng
https://hg.mozilla.org/integration/mozilla-inbound/rev/bdfafe991ec6
funcName for CopyTexImage2D should be copyTexImage2D.
https://hg.mozilla.org/integration/mozilla-inbound/rev/32c906431710
Build fixes.
https://hg.mozilla.org/integration/mozilla-inbound/rev/da8a989f65d1
Mark test as passing.
You need to log in before you can comment on or make changes to this bug.