[Keyboard] not showing completely, the lower part is shown with delay, background can be seen, on 319MB flame

RESOLVED DUPLICATE of bug 1137203

Status

()

defect
RESOLVED DUPLICATE of bug 1137203
4 years ago
4 years ago

People

(Reporter: echang, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

(URL)

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

4 years ago
### STR
1. Tap and try to enter something to bring up keyboard

### Actual
Keyboard not showing completely, the lower part is shown with delay, background can be seen
Not happening on 1GB flame

### Version
Serial: e47cd843 (State: device)
Build ID               20150224002637
Gaia Revision          8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gaia Date              2015-02-24 05:00:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2b
70d9d62799
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150224.042644
Firmware Date          Tue Feb 24 04:26:54 EST 2015
Bootloader             L1TC100118D0
QA Whiteboard: [COM=Gaia::Keyboard], [319MB]
Keywords: regression
Summary: [Keyboard → [Keyboard] not showing completely, the lower part is shown with delay, background can be seen, on 319MB flame
(Reporter)

Comment 2

4 years ago
Posted file youtube video
(Reporter)

Updated

4 years ago
(Reporter)

Comment 3

4 years ago
Set 2.2? for breaking existing UI on 319MB flame.
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
QA Contact: pcheng
QA Contact: pcheng → jmercado
Bug 1127066 seems to have caused this issue.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150211190942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150211230942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15

Gaia Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ed69c4d2c15&tochange=07479758ab68
QA Whiteboard: [COM=Gaia::Keyboard], [319MB] → [COM=Gaia::Keyboard], [319MB] [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Botond, can you take a look at this please? This is another issue that might be caused by the work done on bug 1127066.
QA Whiteboard: [COM=Gaia::Keyboard], [319MB] [QAnalyst-Triage?] → [COM=Gaia::Keyboard], [319MB] [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(botond)
Component: Gaia::Keyboard → Panning and Zooming
Product: Firefox OS → Core
319MB flame has an in-process keyboard so this is the same OMTA glitchiness that is infecting the root process now that we have APZ enabled there. I can repro and my patch from bug 1137203 appears to fix it.
Blocks: 1134202
Component: Panning and Zooming → Graphics: Layers
Flags: needinfo?(botond)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137203
You need to log in before you can comment on or make changes to this bug.