wwf.com - I wanna go! pop up does not submit answer even when User name and password are entered

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
major
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Thomas Buffington Jr., Assigned: bc)

Tracking

Details

(Whiteboard: [TOOL][DREAMWEAVER][bug 094], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.6) Gecko/20011120
BuildID:    20011120009

I am registered member on The World Wrestling federation's site and whenever you
enter http://www.wwf.com/ there is a pop up which basically has a question with
four choices and a spot for your user name and password. After putting in my
username and password the answer that to me is correct is entered. 

Upon hitting the sumbit button I am supposed to be re-directed to a screen on
that same popup which lets me know if my answer was correct or not, yet when I
hit sumbit no transfer or redirection takes place. The problem only occurs with
any Mozilla based browser or any Netscape 6.x browser. I tested with Netscape
communicator 4.79 and it sumbits my answer w/o any problem.

Reproducible: Always
Steps to Reproduce:
1.Goto http://www.wwf.com/

2. the pop up of "I wanna go" will now appear

3. It'll give you a question to which if you don't have a username and password
register there. Don't close the pop up, put your username, password and answer
in. Now hit the sumbit button and you will see no transfer, or re-direct occurs.
Try this same thing with IE 6 or any Netscape 4.x and you will see what is
supposed to happen.

Actual Results:  I did all three steps with various browser and was unsuccesful
with the Mozilla 0.9.6 browser and Netscape 6.2 browser however when I did the
steps with IE 6 and Opera 6 even after registering a new user name I was
trasnfered/re-directed to the screen letting me know my answer was right or not.

Expected Results:  Being there is a contest running and the only way to enter is
answering the question correctly I was hoping that the transfer would take place
and that I would be told whether or not the answer was right. The only thing
that happened was I still at Square one looking at the same screen with my
username and password.

Comment 1

16 years ago
Reporter: This isn't a "blocker". That severity level is for extraordinary
evil bugs which prevent developers and QA people from working with Mozilla.
I suggest that you change the severity level to.

When I press the "Register Me!" button (after wasting five minutes of my life
trying to find nonsense values that make enough sense ;-),
absolutely nothing happends as you say. Build ID: 2001 12 10 03. Windows 2000.

However, this can be seen in the JavaScript console:

    Error: uncaught exception: Permission denied to get property Window.bottom

So as a starter, I suggest that you change the component to "JavaScript Engine",
and we'll hear what those guys have to say.

Comment 2

16 years ago
Sorry Thomas, I should have suggested a severity level. Maybe "major" ?
(Assignee)

Comment 3

16 years ago
Uses MM Dreamweaver 3.

http://ursstuff.wwf.com/IWG/top.html
http://ursstuff.wwf.com/IWG/bottom.html
http://application.wwf.com/mod-cgi/iwg/

Trying to do something they do not have permission to do:
Error: uncaught exception: Permission denied to get property Window.scriptglobals
Blocks: 51020
Severity: blocker → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: WWF I wanna go! pop up does not submit answer even when User name and password are entered → wwf.com - I wanna go! pop up does not submit answer even when User name and password are entered
Whiteboard: [TOOL][DREAMWEAVER]
(Reporter)

Updated

16 years ago
Severity: normal → major
OS: Windows ME → Windows XP
(Reporter)

Comment 4

16 years ago
I'm using build ID 2001121803 which is version 0.9.7+ with Windows XP as my OS
and now I am able to enter my password and ID not only that but it transfers me
to the next screen which means the problem for me is solved. Can anyone else try
this and see if the problem is truly fixed?
(Assignee)

Comment 5

16 years ago
pull down menus work for me in moz 2001 12 18 03/win2k and NS6.2.1/win2k.

It will submit the question and login for me in moz 2001 12 18 03/win2k. Assume
that means fixed. Still can not submit question in NS 6.2.1/win2k.
Whiteboard: [TOOL][DREAMWEAVER] → [TOOL][DREAMWEAVER][bug 094]
(Assignee)

Comment 6

16 years ago
fixed in mozilla
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 7

16 years ago
Every time I have loaded the page, Mozilla has crashed.  Actually, Quicktime
says it cannot find a required component, checks it server, and says it is
unavailable.  I then try exiting the popup window and QuickTime crashes and says
I should exit and restart Navigator.  Navigator then crashes.  This may or may
not be related to the original problem, but it is serious and happens on the
same page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

16 years ago
Brant,

What build of Mozilla are you using? and what is your OS? Do you have the 
talkback incident report numbers for the crashes? I'll try the page a bit later 
to see if I can reproduce the problem.

Comment 9

16 years ago
Changing back to Resolved Fixed.  Will try recreating crash later.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
Verified 2002030208/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.